summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 19:13:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:31 +0200
commit7e716439390fd79bb149717652b7c524eb75de8b (patch)
tree8624d1aa9ad8538adfe4cd430f78f3fe7eee3b6e /x11-plugins
parentx11-plugins/wmtz: EAPI8 bump (diff)
downloadgentoo-7e716439390fd79bb149717652b7c524eb75de8b.tar.gz
gentoo-7e716439390fd79bb149717652b7c524eb75de8b.tar.bz2
gentoo-7e716439390fd79bb149717652b7c524eb75de8b.zip
x11-plugins/wmweather: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/32909 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild b/x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild
new file mode 100644
index 000000000000..c8f8ee534cc3
--- /dev/null
+++ b/x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Dockable weather monitor for standard METAR stations using ICAO location"
+HOMEPAGE="https://people.debian.org/~godisch/wmweather/"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-apps/xmessage
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=(
+ "${WORKDIR}"/${P}/CHANGES
+ "${WORKDIR}"/${P}/README
+ )
+
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-fno-common.patch
+}