summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/mate-terminal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/mate-terminal')
-rw-r--r--x11-terms/mate-terminal/Manifest2
-rw-r--r--x11-terms/mate-terminal/mate-terminal-1.8.0.ebuild41
-rw-r--r--x11-terms/mate-terminal/mate-terminal-1.8.1.ebuild41
-rw-r--r--x11-terms/mate-terminal/metadata.xml8
4 files changed, 92 insertions, 0 deletions
diff --git a/x11-terms/mate-terminal/Manifest b/x11-terms/mate-terminal/Manifest
new file mode 100644
index 000000000000..082faa3007f8
--- /dev/null
+++ b/x11-terms/mate-terminal/Manifest
@@ -0,0 +1,2 @@
+DIST mate-terminal-1.8.0.tar.xz 1150588 SHA256 9efe1f9e3ee6ef9bc90e233ebe0a440cdb24761edfb9743dcc8b56f8b7a57c09 SHA512 c672a85afd5188cc883eadeae468750cbe1544a8d95fd6b3af0c5d8b41aaeb563227a4d4effdc4a13ea49d823d2ac28adf4caae4f7b3c68d69f0fc49adfc00fb WHIRLPOOL 6112fb99c37c8049b9d5c9f564a387556b734cc87892afe0cbd6e0cba9777514814a15f71a025da9a3cf1a240bc86ca5257f66a14c5278ce28753fffbf737caf
+DIST mate-terminal-1.8.1.tar.xz 1160064 SHA256 d4ba3fd495feb4f8836ea9ca4c201c78fe9564c8190a2d3c84ca4e514a7aa39d SHA512 fec2b2a48ca5a6218a73694627e9a690f61be9706c12999428467755949a47d1f57fb5767370fe9c1fba02333b4802ecbebae0b7f87f547539cdd1b3eaa44ee1 WHIRLPOOL 8d1ed15964ffc67d22094c52a68b6c88aded026511d3de2c9bf9c0a494424ae27f5f234db5b9e2ce29eabfd512605cd478a5f255b22f6281f8da536fb5298cbd
diff --git a/x11-terms/mate-terminal/mate-terminal-1.8.0.ebuild b/x11-terms/mate-terminal/mate-terminal-1.8.0.ebuild
new file mode 100644
index 000000000000..308e891326cc
--- /dev/null
+++ b/x11-terms/mate-terminal/mate-terminal-1.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE Terminal"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+RDEPEND="app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/glib-2.25:2
+ >=gnome-base/dconf-0.10:0
+ >=mate-base/mate-desktop-1.8:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ x11-libs/pango:0
+ >=x11-libs/vte-0.27.1:0"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
diff --git a/x11-terms/mate-terminal/mate-terminal-1.8.1.ebuild b/x11-terms/mate-terminal/mate-terminal-1.8.1.ebuild
new file mode 100644
index 000000000000..2268495b7f7e
--- /dev/null
+++ b/x11-terms/mate-terminal/mate-terminal-1.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE Terminal"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/glib-2.25:2
+ >=gnome-base/dconf-0.10:0
+ >=mate-base/mate-desktop-1.8:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ x11-libs/pango:0
+ >=x11-libs/vte-0.27.1:0"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
diff --git a/x11-terms/mate-terminal/metadata.xml b/x11-terms/mate-terminal/metadata.xml
new file mode 100644
index 000000000000..8cdad0d38750
--- /dev/null
+++ b/x11-terms/mate-terminal/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-terminal</remote-id>
+ </upstream>
+</pkgmetadata>