summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-07-04 22:24:55 +0100
committerEli Schwartz <eschwartz@gentoo.org>2024-07-11 12:28:31 -0400
commit31ee54bb8083189dfdac1d5eebc91631e18a3bb1 (patch)
tree05d43277f12639189d6edbca4ae3c67c92fc906a /x11-terms
parentapp-editors/neovim: 9999 needs dev-libs/libutf8proc to build (diff)
downloadgentoo-31ee54bb8083189dfdac1d5eebc91631e18a3bb1.tar.gz
gentoo-31ee54bb8083189dfdac1d5eebc91631e18a3bb1.tar.bz2
gentoo-31ee54bb8083189dfdac1d5eebc91631e18a3bb1.zip
x11-terms/terminator: add 2.1.4
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/37438 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminator/Manifest2
-rw-r--r--x11-terms/terminator/terminator-2.1.4.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-terms/terminator/Manifest b/x11-terms/terminator/Manifest
index 10675b38f76c..dcf0bd6562ff 100644
--- a/x11-terms/terminator/Manifest
+++ b/x11-terms/terminator/Manifest
@@ -1,2 +1,4 @@
DIST terminator-2.1.3.tar.gz 1046741 BLAKE2B 39ec3ca049d5fb532e420ab48a609bd254d626e1949b7c659c85a451054ec4c6f59c89940b2a618131933090fa70aa4441ab88abf2a302d84f6c9b2c61bb22c6 SHA512 79bdf22f068e14cd63e527f3671cd7b06f2685ef12594870aee170f858a8eabb21e63e7a9ef41fcc664e9b34e8f24b08e998de686be7bf47e0d4315c1224bb8e
DIST terminator-2.1.3.tar.gz.asc 866 BLAKE2B 02ab0c100924da02f76bbf557b99743dbd03af727f67e4824afb099e6760b1acac468c31d4f083efa698738d697d834707fbed105eb0caf7db96438bc4818feb SHA512 48e450d5aa3bef23ec3381c3e24e5ab60b35aa76758cc9d1894a68f04d0f9784fee79e03500cff1473b5f7468816604a0e62b7ee709273d25167e54a8be08279
+DIST terminator-2.1.4.tar.gz 1065856 BLAKE2B 6ac6393ddd694ad2a981ad5d225a28831d792f117b6cad30961fc77142ba945312d8ad762270860a86e9a6ee8104822c1b2b3f27ce97a405f45dab90c976f5b1 SHA512 8bc4445f19d67f968422f482ee93d01229c38f41747e48fced88b083da2a38b2176d679bca5391c5a7ea7e89537bd9ecf5ee79dd01f138f41db50afab1dbed6a
+DIST terminator-2.1.4.tar.gz.asc 866 BLAKE2B 9aa976faad2067de357990bd097ec42879603f0e313613b8e2bba78aaa10c5761f66715221c0fb38e92e0a4bff1a9a993777100a12ee21dc05004add4f624fbd SHA512 2b14b2d2d2bbd9c5380fdc8612868a752cd6eb2c3b9b1e5adc2846deaa16983992e383be602cf729ba1b6af3427c9bb5ba26f9794272fbf7fa0f4d50b933df37
diff --git a/x11-terms/terminator/terminator-2.1.4.ebuild b/x11-terms/terminator/terminator-2.1.4.ebuild
new file mode 100644
index 000000000000..f20be37dbf5e
--- /dev/null
+++ b/x11-terms/terminator/terminator-2.1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 optfeature verify-sig virtualx xdg
+
+DESCRIPTION="Multiple GNOME terminals in one window"
+HOMEPAGE="https://github.com/gnome-terminator/terminator"
+SRC_URI="
+ https://github.com/gnome-terminator/terminator/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/gnome-terminator/terminator/releases/download/v${PV}/${P}.tar.gz.asc )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas[introspection]
+ x11-libs/gtk+:3
+ x11-libs/vte:2.91[introspection]
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ test? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ x11-libs/libnotify[introspection]
+ )
+ verify-sig? ( sec-keys/openpgp-keys-terminator )
+"
+distutils_enable_tests pytest
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/terminator.asc
+
+PATCHES=(
+ "${FILESDIR}"/terminator-1.91-desktop.patch
+)
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "D-Bus" dev-python/dbus-python
+ optfeature "desktop notifications" "x11-libs/libnotify[introspection]"
+ optfeature "global keyboard shortcuts" "dev-libs/keybinder:3[introspection]"
+}