summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-10 05:07:50 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-10 05:15:49 -0400
commita715dabd8e32b9b4d6d09921cf97ee3d1b0cda87 (patch)
tree3b8fb5ecb051eb7a8616fe668caf716446060637 /x11-terms
parentx11-terms/kitty-terminfo: add 0.29.0 (diff)
downloadgentoo-a715dabd8e32b9b4d6d09921cf97ee3d1b0cda87.tar.gz
gentoo-a715dabd8e32b9b4d6d09921cf97ee3d1b0cda87.tar.bz2
gentoo-a715dabd8e32b9b4d6d09921cf97ee3d1b0cda87.zip
x11-terms/kitty: add 0.29.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.29.0.ebuild165
2 files changed, 168 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 096fec6c58fe..e633f957f465 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -4,3 +4,6 @@ DIST kitty-0.27.1.tar.xz.sig 566 BLAKE2B 49cb96d99c48cfe74a50191687fac269cdc3314
DIST kitty-0.28.1-vendor.tar.xz 1344988 BLAKE2B 768a2859f18b743a23007be60323035f54375496cb08d45dabab12ca09b3227451f7c1e78dda72bc79712835e1e0541549b1c1f7b5f68f8b1164062c77ba7520 SHA512 bc111e7428660d79e116a88f0c62c4dc54c79c423c364156219c5a6251f0725fc43e34e8b518352b00433c2443371619b4f6ab5c41d32ddf129c42f98ced0694
DIST kitty-0.28.1.tar.xz 7850232 BLAKE2B 18567e54bbd2ac183120122847951744bb8494829911d4c66b5db23488fcc257c895b8d788c1b386ffec832aceb4f691a8a10339be07d43e54957c9c98365a01 SHA512 a8863c8bf5a3c385671d98bd50481ffcd3984e45ee051173eb38de9aac79643e69a312e08b8f655759f3ecdfab4efe38dca39167f5590e482748b5e85dea5537
DIST kitty-0.28.1.tar.xz.sig 566 BLAKE2B 5ad5fa8fa0143dcd5760dbd885c718582e5001d2eeb5b6b559abffd556407e1061ebe9c84757f49c57803233f38ebe6f7d813f9f50a55b7ce8532c0f589cd8ae SHA512 cf13e09978187c19d53903aea0032ef2088950eb050e0d183283919e96d9a2ae14dd2a40f63ee0fc5180be3e5a9066ade86943f1bcac042d6da890fa2ed13720
+DIST kitty-0.29.0-vendor.tar.xz 1377160 BLAKE2B f0ab044a117d3592aa7c26a7401d93f3a4315f81a7612eeb8ba34be4f154955d7f6662adec7b0710484bfb5284aa0750bb19ab0c07279c74a9b3b4e42770d262 SHA512 b8c8bd91e5b8e711546d476b1c37dd5c15b9f5f02109279b75f6b27f994e910418c9429ba74bb170315df0e5e01ef235eecc8ade0b8d8a0effb97333ae18ce99
+DIST kitty-0.29.0.tar.xz 7812720 BLAKE2B bbcc08cb474bf0d9faff0a32244a4ce374da170b78dbeb74bf720ab431c51a8899d2ecaccf45a9063531ea9db51340ddd08bc72cb933cd9c812e89c176ecb32a SHA512 d8d13dea92d21ad113e3f6b056b2ea31514e0893b04c2bac2665821bb66ec10fdadacbf19e22980e0e744ef9d272f2fc2b4981016b182509af2040b6f4267d3c
+DIST kitty-0.29.0.tar.xz.sig 566 BLAKE2B 8755e62df9766fe742447e77d4d8c22303deac91a754cf0ef0cbd62ace6b1b48d48d5a703c6e96cbbdcf8c6527792b0f74dd4ef8c79eca3bc4fb9e719805d098 SHA512 741dcf20254e8e63333500d42c4cd4fa6f61497b511c330f7ceeb8bc75322c0c3c65baac6e29b48ae4e2fb6455b5d39d0988284694ccd269bde70adacd43ca34
diff --git a/x11-terms/kitty/kitty-0.29.0.ebuild b/x11-terms/kitty/kitty-0.29.0.ebuild
new file mode 100644
index 000000000000..ca29cc5189de
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.29.0.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )"
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ media-libs/fontconfig
+ media-libs/harfbuzz:=
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ net-libs/librsync:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.20
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}