summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-21 16:38:26 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-21 17:23:42 -0700
commit5dee28086b6087e4391e4de46f860e17fd08ff01 (patch)
tree764f8f3fae1ac95f508f017663f26e3dcbc7ee01 /x11-themes/adwaita-icon-theme
parentsys-boot/tboot: Remove old (diff)
downloadgentoo-5dee28086b6087e4391e4de46f860e17fd08ff01.tar.gz
gentoo-5dee28086b6087e4391e4de46f860e17fd08ff01.tar.bz2
gentoo-5dee28086b6087e4391e4de46f860e17fd08ff01.zip
x11-themes/adwaita-icon-theme: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-themes/adwaita-icon-theme')
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest1
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
index db360ef9e0ea..3574db5ee8fd 100644
--- a/x11-themes/adwaita-icon-theme/Manifest
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -1,3 +1,4 @@
DIST adwaita-icon-theme-3.32.0.tar.xz 18540012 BLAKE2B a82ca6758cdbf459ac617d3b3d834e4147c3a3c5e6ca7c705ed2d16e8cf0a1255f5ae999d7e930b9716585b8c498c220f1ab40fec929dde7679efd56f3b18a45 SHA512 9609732cd51c6794d4d86598818bb2a589b0f4b6b795e57f3507dad69b21ef1b2fc2e83e24e937428bbace32fcccf587a5771cbc02c5768206e704f0456a6d1d
DIST adwaita-icon-theme-41.0.tar.xz 17086916 BLAKE2B 6899bf734a3f708e6596a4aeb2df426041dd46232a3cbd55f530fab2cc92277db74322a31a443e251a06c74bf7fad7d5f9394b63edb33fced5ce8987e5c87d3e SHA512 2a540f2b53cb64433780029ea70c2cfe8417ae7e619d8eefa59825e3ebcb8585acd4ccae25344c8e146a0ee0705ccbb39a2cb729a162534fd86a4ff24e505c86
+DIST adwaita-icon-theme-42.0.tar.xz 10407000 BLAKE2B 1ec998731b8da4ed17d7bb5887faba7a33721955836265c67efeffcf16bbb82e6f20750245b9b6d7dc4e816ec0e6ae71cb51a839debb0e070edf5d347d6260d5 SHA512 521bfd44fdc253f5fd01fcdfaa485669849ad73c35354ccfe9b358ba433cfa40ee6d68b70ec2268a4ce0631a48670b03b30811ca68e2e19f9430082454e02015
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0.ebuild
new file mode 100644
index 000000000000..7154dd1d95ab
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.48:2
+"
+BDEPEND="
+ >=gnome-base/librsvg-2.48:2
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-libs/gtk+:3
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place used in Gentoo
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}