summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-14 10:27:03 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-14 10:28:09 +0100
commita4a7fd9fc06b9354c110cd36b1ca35f1b9dc032d (patch)
treeaf4de2f679fff1b0ba2915e1ea789c74af59de1d /x11-themes/gartoon-redux
parentapp-cdr/cdrdao: Add AM_GCONF_SOURCE_2 macro to patch (diff)
downloadgentoo-a4a7fd9fc06b9354c110cd36b1ca35f1b9dc032d.tar.gz
gentoo-a4a7fd9fc06b9354c110cd36b1ca35f1b9dc032d.tar.bz2
gentoo-a4a7fd9fc06b9354c110cd36b1ca35f1b9dc032d.zip
x11-themes/gartoon-redux: rsvg -> rsvg-convert (bug #574440 by Toralf Förster).
Patch configure to use rsvg-convert with correct options Work around parallel make failure Depend on dev-perl/Switch Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-themes/gartoon-redux')
-rw-r--r--x11-themes/gartoon-redux/files/gartoon-redux-1.10-rsvg-convert.patch11
-rw-r--r--x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild45
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-themes/gartoon-redux/files/gartoon-redux-1.10-rsvg-convert.patch b/x11-themes/gartoon-redux/files/gartoon-redux-1.10-rsvg-convert.patch
new file mode 100644
index 000000000000..411b4537df49
--- /dev/null
+++ b/x11-themes/gartoon-redux/files/gartoon-redux-1.10-rsvg-convert.patch
@@ -0,0 +1,11 @@
+--- a/configure
++++ b/configure
+@@ -150,7 +150,7 @@
+ my $size = shift;
+ my $zoom_factor = $size / 90;
+ return "$target: $source\n" .
+- "\trsvg -x $zoom_factor -y $zoom_factor $source $target";
++ "\trsvg-convert -x $zoom_factor -y $zoom_factor $source -o $target";
+ }
+
+ sub usage {
diff --git a/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
new file mode 100644
index 000000000000..ea8a1092bae5
--- /dev/null
+++ b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils
+
+DESCRIPTION="A massively improved variant of the well-known Gartoon theme"
+HOMEPAGE="http://gnome-look.org/content/show.php/?content=74841"
+SRC_URI="http://tweenk.artfx.pl/gartoon/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-perl/Switch
+ gnome-base/librsvg
+"
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.10-rsvg-convert.patch
+}
+
+src_configure() {
+ # perl script, not autotools based
+ ./configure --prefix=/usr || die
+}
+
+src_compile() {
+ emake prepare
+ emake
+}
+
+src_install() {
+ emake icondir="${D}"/usr/share/icons/GartoonRedux install
+ dodoc AUTHORS changelog README TODO
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }