summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-16 18:17:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-16 18:17:34 +0100
commit4cbd99704779cf34eeda8487a12f11c0e7aaef27 (patch)
tree890387d426d785a3949d6036e95b65df6ced6038 /x11-themes/qtcurve
parentdev-util/cmake: Drop 3.22.1 (diff)
downloadgentoo-4cbd99704779cf34eeda8487a12f11c0e7aaef27.tar.gz
gentoo-4cbd99704779cf34eeda8487a12f11c0e7aaef27.tar.bz2
gentoo-4cbd99704779cf34eeda8487a12f11c0e7aaef27.zip
x11-themes/qtcurve: Fix "unused" cmake var
Closes: https://bugs.gentoo.org/833390 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-themes/qtcurve')
-rw-r--r--x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild4
-rw-r--r--x11-themes/qtcurve/qtcurve-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild b/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild
index f36d3ed37985..4b85cc310ca3 100644
--- a/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild
+++ b/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -71,8 +71,8 @@ src_configure() {
-DBUILD_TESTING="$(usex test)"
-DQTC_ENABLE_X11="$(usex X)"
-DQTC_INSTALL_PO="$(usex nls)"
- -DQTC_QT5_ENABLE_KDE="$(usex plasma)"
)
+ use qt5 && mycmakeargs+=( -DQTC_QT5_ENABLE_KDE="$(usex plasma)" )
cmake_src_configure
}
diff --git a/x11-themes/qtcurve/qtcurve-9999.ebuild b/x11-themes/qtcurve/qtcurve-9999.ebuild
index 0d206bafd695..805ba185c700 100644
--- a/x11-themes/qtcurve/qtcurve-9999.ebuild
+++ b/x11-themes/qtcurve/qtcurve-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -75,8 +75,8 @@ src_configure() {
-DBUILD_TESTING="$(usex test)"
-DQTC_ENABLE_X11="$(usex X)"
-DQTC_INSTALL_PO="$(usex nls)"
- -DQTC_QT5_ENABLE_KDE="$(usex plasma)"
)
+ use qt5 && mycmakeargs+=( -DQTC_QT5_ENABLE_KDE="$(usex plasma)" )
cmake_src_configure
}