summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/emerald
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/emerald')
-rw-r--r--x11-wm/emerald/Manifest1
-rw-r--r--x11-wm/emerald/emerald-0.8.8.ebuild58
-rw-r--r--x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch12
-rw-r--r--x11-wm/emerald/metadata.xml6
4 files changed, 77 insertions, 0 deletions
diff --git a/x11-wm/emerald/Manifest b/x11-wm/emerald/Manifest
new file mode 100644
index 000000000000..5fd731161280
--- /dev/null
+++ b/x11-wm/emerald/Manifest
@@ -0,0 +1 @@
+DIST emerald-0.8.8.tar.bz2 528715 SHA256 239285ced20e817f5303e935d922236f828ca905b264833005a330df2089e8a3 SHA512 c19300ed03b168a01d3c8b7fd90e9f594d5a8165b04d5228de2294301f31619f1126e9ce618e49d666e5b5609eb52ea1434f165f67dc6843ae17b6664305427e WHIRLPOOL d420c2022c2a98263b8e50c1fd51ce8d80c2dca70d161b7864ba706850d3bbb68ebd3baac111999d7c3c7a058fd9cbc1c67eeebc51eca0067edad4481f65b15c
diff --git a/x11-wm/emerald/emerald-0.8.8.ebuild b/x11-wm/emerald/emerald-0.8.8.ebuild
new file mode 100644
index 000000000000..921726a76801
--- /dev/null
+++ b/x11-wm/emerald/emerald-0.8.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils flag-o-matic
+
+THEMES_RELEASE=0.5.2
+
+DESCRIPTION="Emerald Window Decorator"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+PDEPEND="~x11-themes/emerald-themes-${THEMES_RELEASE}"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.8.0:2
+ >=x11-libs/libwnck-2.14.2:1
+ >=x11-wm/compiz-${PV}
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.15
+"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO )
+
+src_prepare() {
+ # Fix pkg-config file pollution wrt #380197
+ epatch "${FILESDIR}"/${P}-pkgconfig-pollution.patch
+ # fix build with gtk+-2.22 - bug 341143
+ sed -i -e '/#define G[DT]K_DISABLE_DEPRECATED/s:^://:' \
+ include/emerald.h || die
+ # Fix underlinking
+ append-libs -ldl -lm
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-fast-install \
+ --disable-mime-update
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch b/x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch
new file mode 100644
index 000000000000..047d8dfad786
--- /dev/null
+++ b/x11-wm/emerald/files/emerald-0.8.8-pkgconfig-pollution.patch
@@ -0,0 +1,12 @@
+--- libengine/emeraldengine.pc.in
++++ libengine/emeraldengine.pc.in
+@@ -7,6 +7,7 @@
+ Description: Library for Emerald Engines
+ Version: @VERSION@
+
+-Requires: @EMERALD_REQUIRES@
+-Libs: @EMERALD_LIBS@
++Requires.private: @EMERALD_REQUIRES@
++Libs: -L${libdir} -lemeraldengine
++Libs.private: @EMERALD_LIBS@
+ Cflags: @EMERALD_CFLAGS@ -I${includedir}/emerald
diff --git a/x11-wm/emerald/metadata.xml b/x11-wm/emerald/metadata.xml
new file mode 100644
index 000000000000..13d892cb8836
--- /dev/null
+++ b/x11-wm/emerald/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-effects</herd>
+<longdescription lang="en">Emerald is a 3D window decorator for compositing window managers such as compiz.</longdescription>
+</pkgmetadata>