summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-31 08:15:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-31 08:17:29 +0100
commit953390c8f425eb6f0fb5b70ac3340e8e8900ccbf (patch)
tree12e005785e91727c50a15edcbbf2dc396603b5a3 /xfce-base/thunar
parentdev-python/pypy3_10: Fix cffi .dist-info (diff)
downloadgentoo-953390c8f425eb6f0fb5b70ac3340e8e8900ccbf.tar.gz
gentoo-953390c8f425eb6f0fb5b70ac3340e8e8900ccbf.tar.bz2
gentoo-953390c8f425eb6f0fb5b70ac3340e8e8900ccbf.zip
xfce-base/thunar: Bump to 4.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.19.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index cbcf500b59ba..15377bb9a543 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -3,3 +3,4 @@ DIST thunar-4.18.8.tar.bz2 2844536 BLAKE2B dbd61d387f21956edad5f5f614c170b072788
DIST thunar-4.18.9.tar.bz2 2846241 BLAKE2B 2b3ba7738f355d46207a74a3d37fca19403cf1f50c2d1c4e616286e62f98456fc072c3e47246b5562b1f70e34fb6ed9120bebae53095cec971d1cad3c1b01004 SHA512 44fd0aec2d12a63db50591124f210f2da2f2d9b0a105191b5e958eec83811578af43deb05990efe417f8dceabb2ea95fcb3af7285d184a9e8c6f36006a601dee
DIST thunar-4.19.0.tar.bz2 2924690 BLAKE2B 9d8cf10d3eae16c84489098b28020470b353f970ea561ff8dce2caccd7086ed39cae3796df26489b3a8586c0bd8d008a2d9953017b71cad2a760d498b60c1b15 SHA512 1db58776fe39f9f4c2f215b52a2209dac773e8b708e4796752630703531e1ddd9017e32e1fe779c5fcc5d543438bbebf14f510b9361fde22fe0045ac0fd3a87f
DIST thunar-4.19.1.tar.bz2 2924598 BLAKE2B 6d4deb37820232b21cc4f8f285647d64c55353bece00cc9eb3b22dd64a477f2c637dd2d5e244cc629f45749cd4627237cf2feaafbd45038483cbee942f280221 SHA512 95ecdd042f9cf1b755ffc6ad572ffdfba33395ae93884e018b45426dd5f119097b122b4d9976839db78012c9bbcdd0cf1cd129904e06cf990978a711cbd48257
+DIST thunar-4.19.2.tar.bz2 2923969 BLAKE2B 282b22124bd6f952ef05dfdfc302e0626748ab3ab3bb0f5052358d8612177c4f2df1225424ba2db65aebd986cf4966afb972ccb81945e61402ba53693ba538a3 SHA512 edc653656bc9896281783b482b343ce06cd524d16b59dac5e76ff3a48f7941b2a9256c43639120438c3377944f1d4faffe98da470181feee8334c1019b35acb4
diff --git a/xfce-base/thunar/thunar-4.19.2.ebuild b/xfce-base/thunar/thunar-4.19.2.ebuild
new file mode 100644
index 000000000000..6bfa97ad9d27
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.19.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/start
+ https://gitlab.xfce.org/xfce/thunar/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+DEPEND="
+ >=dev-libs/glib-2.70.0
+ >=x11-libs/gdk-pixbuf-2.40.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/exo-4.19.0:=
+ >=xfce-base/libxfce4ui-4.17.6:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre2-10.0:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? (
+ >=gnome-base/gvfs-1.18.3
+ )
+ udisks? (
+ >=gnome-base/gvfs-1.18.3[udisks,udev]
+ virtual/udev
+ )
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre pcre2)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}