summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-15 20:21:22 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-15 20:33:22 +0100
commit18ab365f10b9e6d7b3b86331ef78b28100f3bf5b (patch)
treec2b4521fe45aa3aa25236ceab7867cc48b60672c /xfce-base
parentxfce-base/libxfce4ui: Drop old (diff)
downloadgentoo-18ab365f10b9e6d7b3b86331ef78b28100f3bf5b.tar.gz
gentoo-18ab365f10b9e6d7b3b86331ef78b28100f3bf5b.tar.bz2
gentoo-18ab365f10b9e6d7b3b86331ef78b28100f3bf5b.zip
xfce-base/libxfce4ui: Bump to 4.13.4, add vala support
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.13.4.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index c13e86d94518..c07cc9a7a925 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.13.0.tar.bz2 688646 BLAKE2B 72f9bb12e31f8015ca78c83ae7eeab7a81961e279f81c039e83f8dacf149cacd64c9262c1d925d1620c7993184ed65006e5acbe642fc3cbd949712fcdc360cdc SHA512 342c4fb09b3f13e066b994c54cd557a65c116566b8201217cb663851ba387932cdd4ebf2274f32bdc97a98b3a2bd1b59de75ef6cc4c6f5d0e5f1910b7eca591e
DIST libxfce4ui-4.13.3.tar.bz2 705465 BLAKE2B 47879b7dc952c351eb7a6266346c784a902f724b2e8bfc0b66860b12c15885e569a112a67c3087eceaa019256760f11c29f0c05d7b59b746bf6740fe3db81f93 SHA512 eef93a71fe41102eb402878e908b1e2e24060869235e1fff93e65bd480fa3ac53f1beba3b26d061b1962b3c3eefa77cb122e796609ab4b5f6fead353167cc396
+DIST libxfce4ui-4.13.4.tar.bz2 684065 BLAKE2B 1da875832683b5e06b8e91b4078be8122ae85a91560d7b1768cb8c880fcf5e1d7cd07d24927ae3325ba9c500c6c2cd30e717e517775492b9948add0711f5aa40 SHA512 c82d6ff7ea0da4fc0f664bab92f1e9531162996a26bb092e6ba651cfc4551732cbcd8023908d428b47906c17c331c14bf4804256566ca564befa218dc1194206
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.13.4.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.13.4.ebuild
new file mode 100644
index 000000000000..85f4830a8e84
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.13.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection startup-notification vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=x11-libs/gtk+-2.24:2=
+ >=x11-libs/gtk+-3.18:3=[introspection?]
+ x11-libs/libX11:=
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ >=xfce-base/libxfce4util-4.12:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ startup-notification? ( x11-libs/startup-notification:= )
+ vala? ( $(vala_depend) )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ # TODO: check revdeps and make it optional one day
+ --enable-gtk2
+ # requires deprecated glade:3 (gladeui-1.0), bug #551296
+ --disable-gladeui
+ # this one's for :3.10
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}