summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-10-25 13:07:39 +0800
committerJason Zaman <perfinion@gentoo.org>2016-10-25 13:07:39 +0800
commit637d52d3c1047ab58fb02d032ceda0b67dde22fb (patch)
tree865fd4d6f08e5b3c5941e778d9421d0a4c9b8904 /xfce-base
parentx11-libs/libXfont2: Add 9999 ebuild. (diff)
downloadgentoo-637d52d3c1047ab58fb02d032ceda0b67dde22fb.tar.gz
gentoo-637d52d3c1047ab58fb02d032ceda0b67dde22fb.tar.bz2
gentoo-637d52d3c1047ab58fb02d032ceda0b67dde22fb.zip
xfce-base/xfconf: bump to 4.12.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.12.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index f3c136b20fa6..0f94d4c693dc 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1 +1,2 @@
DIST xfconf-4.12.0.tar.bz2 542544 SHA256 9910eaea8405336415d4d7f3056403f8c67bc23ba0dce251eac35205c603b156 SHA512 60cc37a7207b0486f7f2de665870facf8e339241df344d7540082f3db447b3ac88bddd306d6a09a3868878cb477d1696491c71470052ef56cb649d773bd55b56 WHIRLPOOL 73241764a03c865c3bcda97a481e4ed9c6bfd8a3fdfd1a614291abad32f11157ba50a14d0ef918ad3c397fdd015d3dcf0cd07e24e43fbdd5125d5c273d536c16
+DIST xfconf-4.12.1.tar.bz2 564131 SHA256 35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36 SHA512 114dba6a78d43b25eebfd9ef78beec75391b0c77e736e66ae2b04fe97dc281f93d05467ddfdd63a5067f44de135347564fe55928ae7de72f0984339db411d77f WHIRLPOOL 17ccadbf9759cf2c84f09f58f0f3c65a49a4dab3965a1deb7a42d5635075b4d60dc96556d0cc80d8b8df8c91bae51d9e3864409020b32058694d15f340d3f9c1
diff --git a/xfce-base/xfconf/xfconf-4.12.1.ebuild b/xfce-base/xfconf/xfconf-4.12.1.ebuild
new file mode 100644
index 000000000000..bab084961a6e
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.12.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A flexible, easy-to-use configuration management system for Xfce"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris"
+IUSE="debug perl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.30
+ >=xfce-base/libxfce4util-4.10
+ perl? (
+ dev-lang/perl:=[-build(-)]
+ dev-perl/glib-perl
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ perl? (
+ dev-perl/ExtUtils-Depends
+ dev-perl/extutils-pkgconfig
+ )"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable perl perl-bindings)
+ $(xfconf_use_debug)
+ $(use_enable debug checks)
+ --with-perl-options=INSTALLDIRS=vendor
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS TODO )
+}
+
+src_prepare() {
+ # https://bugzilla.xfce.org/show_bug.cgi?id=9556
+ cat <<-EOF >> po/POTFILES.skip
+ xfconf-perl/xs/Xfconf.c
+ xfconf-perl/xs/XfconfBinding.c
+ xfconf-perl/xs/XfconfChannel.c
+ EOF
+ xfconf_src_prepare
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -exec rm -f {} +
+ find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} +
+ fi
+}