summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-21 07:57:14 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-21 08:04:18 +0100
commit0ee322829898f82a25c2924b2e496a6af21cf6ae (patch)
treec3dbd36285d458a2e9f4246ea3004b832c1c5c30 /xfce-extra
parentdev-ruby/simplecov: add 0.14.1 (diff)
downloadgentoo-0ee322829898f82a25c2924b2e496a6af21cf6ae.tar.gz
gentoo-0ee322829898f82a25c2924b2e496a6af21cf6ae.tar.bz2
gentoo-0ee322829898f82a25c2924b2e496a6af21cf6ae.zip
xfce-extra/xfce4-notifyd: Bump to 0.3.6
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest1
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index de77f5f7295a..92caff4a72e0 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -5,3 +5,4 @@ DIST xfce4-notifyd-0.3.2.tar.bz2 431023 SHA256 c554db55d9d759c32115e9e5da029bd68
DIST xfce4-notifyd-0.3.3.tar.bz2 433388 SHA256 986c4cfeb64c21c6bfb2fe65839490ad0f501fdfc8ed10cc71815da5da110f73 SHA512 c151629c7454f9654aebd66e100b763a773aafc947fcf96097aea7a3d4126600fde5c1612e27fc0cb24e641bf71517250caa8fcdd2acde267eafe74aada03b95 WHIRLPOOL 33546e24ce4dae6becb34b3ff95d8edbefc27522e9258180ea575644a94c0cc76e8f2ff8ef3840db3e5aaae8038dd19c1a11917ff4a77803012ba4f9933ca91c
DIST xfce4-notifyd-0.3.4.tar.bz2 442087 SHA256 038535de79b7056058e8d6dceb457959949831853c2594a686ec68b037ae31bf SHA512 88d8bdd3d1a05011f9048f8b7823f553bfcbc77ab0085aa4ae9e37bc32e95999067af4a2d839fe51161c4fba453bb54760e1087cf467ae3efe8d67bfe9516719 WHIRLPOOL 895c91de3204d7100c4077b0133e624c64395ef72b273e330c8414d59b5a1fa98d2cd7749c413ee71bdcd8dedaaa071f7218f0f9901a1a0a39d17ceb61b15ee1
DIST xfce4-notifyd-0.3.5.tar.bz2 456299 SHA256 b9b86938bdd31b4a69650d8b76e5cb0a6a30c1aa726130bd803f6c6f1f7af7a6 SHA512 292d5e3ef5358195136592b7b51b893fff03f597cb2bf05ecffd58733e6d130f135d86aa9e3453490eeae2096f3cde9a11627ee074a35d4e1f3a2488a706d10e WHIRLPOOL f5cfe1cd2c84776e1c0b247131cc7f801e948530c79072f8dc1f1d279c489f0eccd2f5a7d816390300031a9fdb40133e3d9e27fa8a6d140e2f57dc04685d1723
+DIST xfce4-notifyd-0.3.6.tar.bz2 458536 SHA256 f4ca7c0dadd3d4cdf8cd3c8ae60ccea77b8cf409f8517161796364eb1d766cf9 SHA512 96067de2e08e29c8e6285796bc4b23087f97286e28adfb485dc20f449ae32e10c8fb743f42585e0e6cda82d713eb6da3cc1d94920eb170b7cfa1e687ffcb3ddf WHIRLPOOL 1553171decf0bed143d0d46388673a0f1c34944de458f34db68a547adf346b4d13a367ad80a1c2159801c56795903cd866dbeb3e882a9fc57ff5e2c84409c9b6
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.6.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.6.ebuild
new file mode 100644
index 000000000000..976b799c9fbd
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-notifyd"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=x11-libs/gtk+-3.14:3=
+ >=x11-libs/libnotify-0.7:=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+pkg_postinst() {
+ GNOME2_ECLASS_ICONS="usr/share/icons/hicolor" \
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ GNOME2_ECLASS_ICONS="usr/share/icons/hicolor" \
+ gnome2_icon_cache_update
+}