summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-09 18:07:03 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-09 18:09:05 +0200
commit9a1e78b6bc749179f83d354f3c1efa1b244e5d8c (patch)
tree85ccc6340fe7511d188a5c4eeaa9fcf6b4a91af4 /xfce-extra
parentpackage.mask: Last rite xfce-extra/xfswitch-plugin (diff)
downloadgentoo-9a1e78b6bc749179f83d354f3c1efa1b244e5d8c.tar.gz
gentoo-9a1e78b6bc749179f83d354f3c1efa1b244e5d8c.tar.bz2
gentoo-9a1e78b6bc749179f83d354f3c1efa1b244e5d8c.zip
xfce-extra/xfce4-vala: Support vala:0.42 (~arch)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r6.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r6.ebuild
new file mode 100644
index 000000000000..2cd1fb8f4fe6
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION=0.42
+VALA_MAX_API_VERSION=${VALA_MIN_API_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="https://wiki.xfce.org/vala-bindings"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/garcon-0.2:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ local myconf=(
+ "--with-vala-api=${VALA_MIN_API_VERSION}"
+ )
+
+ vala_src_prepare
+ econf "${myconf[@]}"
+}