summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild (renamed from dev-python/citeproc-py/citeproc-py-0.4.0.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/citeproc-py/citeproc-py-0.4.0.ebuild b/dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild
index 2e0420e00d44..b81b9c57d500 100644
--- a/dev-python/citeproc-py/citeproc-py-0.4.0.ebuild
+++ b/dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
DESCRIPTION="Yet another Python CSL Processor"
@@ -17,6 +17,8 @@ IUSE=""
PATCHES=( "${FILESDIR}/b1a5f925527093b0b5c11507f379a908e3354820.patch" )
-DEPEND="
+RDEPEND="
dev-python/rnc2rng[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}"