summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/neko/neko-2.3.0-r2.ebuild (renamed from dev-lang/neko/neko-2.3.0-r1.ebuild)11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-lang/neko/neko-2.3.0-r1.ebuild b/dev-lang/neko/neko-2.3.0-r2.ebuild
index 701f48537ec9..f51030b4e47b 100644
--- a/dev-lang/neko/neko-2.3.0-r1.ebuild
+++ b/dev-lang/neko/neko-2.3.0-r2.ebuild
@@ -6,9 +6,10 @@ EAPI=8
inherit flag-o-matic cmake
DESCRIPTION="Neko is a high-level dynamically typed programming language"
-HOMEPAGE="https://nekovm.org/"
+HOMEPAGE="https://nekovm.org/
+ https://github.com/HaxeFoundation/neko/"
-if [[ "${PV}" == *9999* ]]; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/HaxeFoundation/${PN}.git"
else
@@ -23,8 +24,8 @@ LICENSE="MIT"
SLOT="0/${PV}"
IUSE="apache mysql sqlite ssl"
-DEPEND="
- dev-libs/boehm-gc:=
+RDEPEND="
+ dev-libs/boehm-gc:=[threads]
dev-libs/libpcre:=
sys-libs/zlib:=
apache? ( www-servers/apache:2= )
@@ -35,7 +36,7 @@ DEPEND="
net-libs/mbedtls:=
)
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
src_configure() {
# -Werror=strict-aliasing warnings, bug #855641