summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/libmwaw/Manifest1
-rw-r--r--app-text/libmwaw/libmwaw-0.3.17.ebuild52
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild4
3 files changed, 55 insertions, 2 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index ebf8d52a53cf..dd59f700911d 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1 +1,2 @@
DIST libmwaw-0.3.16.tar.xz 1306872 BLAKE2B 29c39ddb2cfe63116cbe7152a4dc3b7f16d402745c0dffd67c07dc42fa1ddee71f391695ead2519b3e1da206e8f437fbd24fa78ce1decfaa55e38a13d5d144e8 SHA512 c043d77e4b0efd7da594c1e370f24ee2d85afcb8a5e28179b4c3d76c8b7925f41ca5361bee12b35af732ef39f34fac46aa3636cb27c179ef9bb2b6feeaa19b0a
+DIST libmwaw-0.3.17.tar.xz 1349700 BLAKE2B 4b5ba8d5133144973609dfbd273ca36cc95e52608c78f6143f7c4283bc2bc6d7ceb22836a693d64fa7408957a3b02a7c9d0a5ab9235aa2d0b9725170441babfc SHA512 c3a1bb079d7e74cd7a23de1501730be21b1b089ef6d4f81ee0001775483c6346da3105b0d67f75523e4e088987bc92b97acb056ec7fc11bb29047109a1cf5ac4
diff --git a/app-text/libmwaw/libmwaw-0.3.17.ebuild b/app-text/libmwaw/libmwaw-0.3.17.ebuild
new file mode 100644
index 000000000000..bd259959df53
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-static
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index 80be3cf4b65b..bd259959df53 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,5 +48,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}