summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/webgen/metadata.xml3
-rw-r--r--dev-ruby/asciimath/asciimath-2.0.4.ebuild4
-rw-r--r--dev-ruby/contracts/contracts-0.17.ebuild10
-rw-r--r--dev-ruby/duktape-rb/Manifest1
-rw-r--r--dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r3.ebuild49
-rw-r--r--dev-ruby/duktape-rb/files/duktape-rb-2.3.0.0_duktape-2.5.0-tests.patch28
-rw-r--r--dev-ruby/erubi/erubi-1.12.0.ebuild4
-rw-r--r--dev-ruby/minitest-power_assert/minitest-power_assert-0.3.1-r1.ebuild (renamed from dev-ruby/minitest-power_assert/minitest-power_assert-0.3.1.ebuild)6
-rw-r--r--dev-ruby/redcarpet/redcarpet-3.6.0.ebuild4
-rw-r--r--dev-ruby/rouge/rouge-4.1.0.ebuild2
-rw-r--r--dev-ruby/sawyer/Manifest2
-rw-r--r--dev-ruby/sawyer/sawyer-0.9.2.ebuild (renamed from dev-ruby/sawyer/sawyer-0.8.2-r1.ebuild)12
-rw-r--r--dev-ruby/set/Manifest1
-rw-r--r--dev-ruby/set/metadata.xml3
-rw-r--r--dev-ruby/set/set-1.0.3.ebuild23
-rw-r--r--dev-ruby/temple/temple-0.10.0.ebuild2
-rw-r--r--dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild4
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.1.0.ebuild41
-rw-r--r--dev-ruby/unindent/unindent-1.0-r2.ebuild (renamed from dev-ruby/unindent/unindent-1.0-r1.ebuild)11
-rw-r--r--eclass/ruby-fakegem.eclass4
-rw-r--r--eclass/ruby-ng.eclass6
22 files changed, 111 insertions, 110 deletions
diff --git a/app-text/webgen/metadata.xml b/app-text/webgen/metadata.xml
index 96be9c2520c6..d5f698f7f2d7 100644
--- a/app-text/webgen/metadata.xml
+++ b/app-text/webgen/metadata.xml
@@ -10,4 +10,7 @@
<flag name="highlight">Enable syntax highlighting for certain plugins</flag>
<flag name="markdown">Markdown support</flag>
</use>
+ <upstream>
+ <remote-id type="github">gettalong/webgen</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-ruby/asciimath/asciimath-2.0.4.ebuild b/dev-ruby/asciimath/asciimath-2.0.4.ebuild
index e68548f7c834..420dc8983a5e 100644
--- a/dev-ruby/asciimath/asciimath-2.0.4.ebuild
+++ b/dev-ruby/asciimath/asciimath-2.0.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/contracts/contracts-0.17.ebuild b/dev-ruby/contracts/contracts-0.17.ebuild
index 66484ff56a9d..dfd63b733363 100644
--- a/dev-ruby/contracts/contracts-0.17.ebuild
+++ b/dev-ruby/contracts/contracts-0.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,3 +17,11 @@ LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE=""
+
+each_ruby_test() {
+ # COLUMNS needed for:
+ # ./spec/contracts_spec.rb:654 # Contracts: Contracts to_s formatting in expected should wrap and pretty print for long return contracts
+ # ./spec/contracts_spec.rb:643 # Contracts: Contracts to_s formatting in expected should wrap and pretty print for long param contracts
+ local -x COLUMNS=80
+ each_fakegem_test
+}
diff --git a/dev-ruby/duktape-rb/Manifest b/dev-ruby/duktape-rb/Manifest
index 8680160526e3..88d0ce3ee9fb 100644
--- a/dev-ruby/duktape-rb/Manifest
+++ b/dev-ruby/duktape-rb/Manifest
@@ -1,2 +1 @@
-DIST duktape-rb-2.3.0.0.tar.gz 1356464 BLAKE2B be7362ddbe6860bcb12c8f8909f66ae525585e628f7be2317b07eb07960f8f25e503dbc89e713e57144cc8108751ac856aa73a16cbd58502e928acf9e116247c SHA512 af4fd45387c3f40cd24bf3c879ef4e0d7efd43ca24f0cb866bf869db7fa9f4add9b60122c0dcfbce5491cdd7479b1414637fa1054078216b9f57fa426feb0154
DIST duktape-rb-2.7.0.0.tar.gz 1385934 BLAKE2B 1a3a7ea2c1469ddf9ac482e4329726e0f96823e75153027cf83155cca796cd0380d816a23d617e4bc40e72215acdc524fcb9575711e585952aeb9c6ed85ede70 SHA512 e91f57c2789aeb26aecbd9759c0b8cda457f290fcbe431fee721d01c1987c64f307f0e042b50cf6b4fa468d41c6365adde8395e2a33a8c637f6524af1c7cf028
diff --git a/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r3.ebuild b/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r3.ebuild
deleted file mode 100644
index a9b26614da2f..000000000000
--- a/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_GEMSPEC="duktape.gemspec"
-RUBY_FAKEGEM_NAME="duktape"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/duktape/extconf.rb)
-
-inherit ruby-fakegem
-
-MY_PN=${PN/-/\.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Ruby bindings to the Duktape JavaScript interpeter"
-HOMEPAGE="https://github.com/judofyr/duktape.rb"
-SRC_URI="https://github.com/judofyr/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ppc ~riscv"
-
-COMMON_DEPEND="dev-lang/duktape:="
-DEPEND+="${COMMON_DEPEND}"
-RDEPEND+="${COMMON_DEPEND}"
-
-ruby_add_bdepend "
- dev-ruby/pkg-config
- dev-ruby/rake-compiler
- dev-ruby/sdoc
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.3.0.0_duktape-2.5.0-tests.patch
- "${FILESDIR}"/${PN}-2.3.0.0_use-system-duktape.patch
-)
-
-RUBY_S=${MY_P}
-
-all_ruby_prepare() {
- rm ext/duktape/duktape.{c,h} ext/duktape/duk_config.h || die "Failed to remove bundled duktape"
-}
-
-each_ruby_test() {
- ${RUBY} test/test_duktape.rb || die
-}
diff --git a/dev-ruby/duktape-rb/files/duktape-rb-2.3.0.0_duktape-2.5.0-tests.patch b/dev-ruby/duktape-rb/files/duktape-rb-2.3.0.0_duktape-2.5.0-tests.patch
deleted file mode 100644
index 20228c480da8..000000000000
--- a/dev-ruby/duktape-rb/files/duktape-rb-2.3.0.0_duktape-2.5.0-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-The parse-error message asserted by two of the tests has changed since
-duktape-2.3.0, it is now
-
-# encoding: ASCII-8BIT
-parse error (line 1, end of input)
-
-This should hopefully cover both cases.
-
---- a/test/test_duktape.rb
-+++ b/test/test_duktape.rb
-@@ -102,7 +102,7 @@
- @ctx.eval_string('{')
- end
-
-- assert_equal "parse error (line 1)", err.message
-+ assert_match /parse error [(]line 1/, err.message
- end
-
- def test_type_error
-@@ -160,7 +160,7 @@
- @ctx.exec_string('{')
- end
-
-- assert_equal "parse error (line 1)", err.message
-+ assert_match /parse error [(]line 1/, err.message
- end
-
- def test_type_error
diff --git a/dev-ruby/erubi/erubi-1.12.0.ebuild b/dev-ruby/erubi/erubi-1.12.0.ebuild
index c839897051d0..5756374c27e4 100644
--- a/dev-ruby/erubi/erubi-1.12.0.ebuild
+++ b/dev-ruby/erubi/erubi-1.12.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
diff --git a/dev-ruby/minitest-power_assert/minitest-power_assert-0.3.1.ebuild b/dev-ruby/minitest-power_assert/minitest-power_assert-0.3.1-r1.ebuild
index 5eeda194feb8..a7d65714a016 100644
--- a/dev-ruby/minitest-power_assert/minitest-power_assert-0.3.1.ebuild
+++ b/dev-ruby/minitest-power_assert/minitest-power_assert-0.3.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
diff --git a/dev-ruby/redcarpet/redcarpet-3.6.0.ebuild b/dev-ruby/redcarpet/redcarpet-3.6.0.ebuild
index 408b5e2e2f60..1fc815d18a79 100644
--- a/dev-ruby/redcarpet/redcarpet-3.6.0.ebuild
+++ b/dev-ruby/redcarpet/redcarpet-3.6.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOCS="README.markdown CONTRIBUTING.md CHANGELOG.md doc"
RUBY_FAKEGEM_TASK_TEST="test:unit"
@@ -13,9 +13,9 @@ RUBY_FAKEGEM_EXTENSIONS=(ext/redcarpet/extconf.rb)
inherit ruby-fakegem
-SRC_URI="https://github.com/vmg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A Ruby wrapper for Upskirt"
HOMEPAGE="https://github.com/vmg/redcarpet"
+SRC_URI="https://github.com/vmg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
diff --git a/dev-ruby/rouge/rouge-4.1.0.ebuild b/dev-ruby/rouge/rouge-4.1.0.ebuild
index 0e3272b2a092..e0976295e147 100644
--- a/dev-ruby/rouge/rouge-4.1.0.ebuild
+++ b/dev-ruby/rouge/rouge-4.1.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_TASK_TEST="spec"
RUBY_FAKEGEM_RECIPE_DOC="yard"
diff --git a/dev-ruby/sawyer/Manifest b/dev-ruby/sawyer/Manifest
index 4154ff405251..6cdd696fd019 100644
--- a/dev-ruby/sawyer/Manifest
+++ b/dev-ruby/sawyer/Manifest
@@ -1,2 +1,2 @@
-DIST sawyer-0.8.2.tar.gz 15059 BLAKE2B 11a82158493fba69695b4eee15db223a07ebd81f8e39910553ef197a253a3342cffd00045385706c56c6f5e46bf4e20872cf61028acaf02d6f81fa2f640fc09b SHA512 fdaf88d33d87922bd0d44de919b920938b7072ad437db4b98370c507e22e4229ec0c68c613944fd2e20dde060ae5d34de6c001568eb7d1f38098831ca29b0c13
DIST sawyer-0.9.1.tar.gz 15406 BLAKE2B c368aea98b85c55327b7874a75e6e652bddc9a2765a8ef7af3e5ac9bfabd3a4c7900f58c4ab1397d6737b17a11089fa04d1ee60e7beeb96fc8f638c88407328f SHA512 b8703223b46af9972dc57c6f65f3131246bafb88d4ef82b4c5beecc436c2180019b2e6e57ed7c8a5edbcf9a20cc12d85a1115c2f39cd5993aca48efed8f08868
+DIST sawyer-0.9.2.tar.gz 15545 BLAKE2B 83fc7b6776e888ed4f26a21febc93edf954a1d926c14311078b5ecf7db57614472ed42d33ffc30bceb23c4ea1f1b1047cf3c1a0be9feecb4a3c92458938c6c03 SHA512 560c5bb6fd8f73f68b4dc1151608bc3b1f60aec511fef449cd6361a1307e2c1bf64cfa6cc7ad951ce92db22ce90f3318668af31708f0c1ee5909db3684566c72
diff --git a/dev-ruby/sawyer/sawyer-0.8.2-r1.ebuild b/dev-ruby/sawyer/sawyer-0.9.2.ebuild
index 97e52a84ddef..9c8c0ddd5aec 100644
--- a/dev-ruby/sawyer/sawyer-0.8.2-r1.ebuild
+++ b/dev-ruby/sawyer/sawyer-0.9.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="sawyer.gemspec"
@@ -17,13 +17,13 @@ SRC_URI="https://github.com/lostisland/sawyer/archive/v${PV}.tar.gz -> ${P}.tar.
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
ruby_add_rdepend "
- <dev-ruby/faraday-2.0:*
- >=dev-ruby/addressable-2.3.5"
+ <dev-ruby/faraday-3:*
+ >=dev-ruby/addressable-2.3.5
+"
all_ruby_prepare() {
- # Avoid tests that require network acces
+ # Avoid tests that require network access
sed -i -e '/test_blank_response_doesnt_raise/,/^ end/ s:^:#:' test/agent_test.rb || die
}
diff --git a/dev-ruby/set/Manifest b/dev-ruby/set/Manifest
index 523aa8d0ff96..b00e5df18f03 100644
--- a/dev-ruby/set/Manifest
+++ b/dev-ruby/set/Manifest
@@ -1 +1,2 @@
DIST set-1.0.2.tar.gz 14237 BLAKE2B 767e8ea3684a91475f8dfc1190e2a8022b4330071ceb12ee06f76c23d688f6203571c127592adf5de7ff7b5722999d7a7605df8dc5215e183dabd65fb7863c80 SHA512 b64aeb47b7abe1e1245d33cc081c21f36ab66a115a88678c8b99c44149ef87eb1a522f166d8e02abe614623178992758cb88e9a0aea25fee0e39229265eab59c
+DIST set-1.0.3.tar.gz 14549 BLAKE2B 73ced396e10bd65df7e11edf0c553b7fd517dbc74c6f0721c61dba5e70ec730ed98fe45a834224059a5fb84ca60f194b535763f698b7f5e96b45a6118233ecc3 SHA512 5e4effabcfb7034b054ad5276243bf1aab378d0446790fe99c6911970ff1881acc9b704607acab836db75117903b8187d2aeb33e33d9e39d0ee53b41ea7a6086
diff --git a/dev-ruby/set/metadata.xml b/dev-ruby/set/metadata.xml
index 7a38fd1850ff..77b24b04ff24 100644
--- a/dev-ruby/set/metadata.xml
+++ b/dev-ruby/set/metadata.xml
@@ -5,4 +5,7 @@
<email>ruby@gentoo.org</email>
<name>Gentoo Ruby Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">ruby/set</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-ruby/set/set-1.0.3.ebuild b/dev-ruby/set/set-1.0.3.ebuild
new file mode 100644
index 000000000000..5d50e605ce15
--- /dev/null
+++ b/dev-ruby/set/set-1.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="set.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a class to deal with collections of unordered, unique values"
+HOMEPAGE="https://github.com/ruby/set"
+SRC_URI="https://github.com/ruby/set/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/temple/temple-0.10.0.ebuild b/dev-ruby/temple/temple-0.10.0.ebuild
index 888582c76846..1dc63c94a8ec 100644
--- a/dev-ruby/temple/temple-0.10.0.ebuild
+++ b/dev-ruby/temple/temple-0.10.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild b/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
index 95b415ce58ae..80ffd1e3a18f 100644
--- a/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
+++ b/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 53b57245771a..f31a652a34a5 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1 +1,2 @@
DIST tilt-2.0.11.tar.gz 53041 BLAKE2B 2509cc3efe5e6302c8943c00108eeda6ee4b23a18952ad23049e11ea28b397b80a21d34c4d241119f45cedf2a978a2673d857a6cc32d7e26a2016caa510458f9 SHA512 e28e31ab92aa42eada34e0f6c05dab6a54945d07b649588356b1635ba8a36700f6e537e8702613883693501442d21690d8b3690b06f7b9f331192134511b78b7
+DIST tilt-2.1.0.tar.gz 54542 BLAKE2B b2d7729654efb51d9f61afe75476d6620edd7c104c045dc68c6a5e983cea8dec612d2e5013c51ee7736c87d770acdf8e6f186ff156d177f3281e0fb58d0e8422 SHA512 a450bdc51d782169cda2c43b550fad1425d4ee1a8f3c2da0bb1112051eb9ccfd95e903984ed6d3c76b0f322a243021587c6614f6452c385450ff1a985cfbcaa5
diff --git a/dev-ruby/tilt/tilt-2.1.0.ebuild b/dev-ruby/tilt/tilt-2.1.0.ebuild
new file mode 100644
index 000000000000..a1ad7679472a
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/jeremyevans/tilt"
+SRC_URI="https://github.com/jeremyevans/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubi
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ rm -f test/tilt_sasstemplate_test.rb || die
+
+ # Skip tests for unpackaged asciidoctor converter
+ sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
+}
diff --git a/dev-ruby/unindent/unindent-1.0-r1.ebuild b/dev-ruby/unindent/unindent-1.0-r2.ebuild
index 064501bbac12..c3312706bb8e 100644
--- a/dev-ruby/unindent/unindent-1.0-r1.ebuild
+++ b/dev-ruby/unindent/unindent-1.0-r2.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
DESCRIPTION="Ruby method to unindent strings"
HOMEPAGE="https://github.com/mynyml/unindent"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+LICENSE="MIT"
SLOT="0"
-IUSE=""
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
ruby_add_bdepend "test? ( dev-ruby/nanotest )"
diff --git a/eclass/ruby-fakegem.eclass b/eclass/ruby-fakegem.eclass
index 8cf5dd70f864..9ef5e1f098d1 100644
--- a/eclass/ruby-fakegem.eclass
+++ b/eclass/ruby-fakegem.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: ruby-fakegem.eclass
@@ -552,7 +552,7 @@ each_fakegem_test() {
case ${RUBY_FAKEGEM_RECIPE_TEST} in
rake)
- MT_NO_PLUGINS=true ${RUBY} --disable=did_you_mean -S rake ${RUBY_FAKEGEM_TASK_TEST} || die "tests failed"
+ MT_NO_PLUGINS=true ${RUBY} --disable=did_you_mean -S rake ${RUBY_FAKEGEM_TASK_TEST} || die -n "tests failed"
;;
rspec)
RSPEC_VERSION=2 ruby-ng_rspec
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index 67c22d518a31..f85a933f81d9 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -699,7 +699,7 @@ ruby-ng_rspec() {
fi
if [[ "${DEPEND}${BDEPEND}" != *"dev-ruby/rspec"* ]]; then
- ewarn "Missing test dependency dev-ruby/rspec"
+ eqawarn "Missing test dependency dev-ruby/rspec"
fi
local rspec_params=
@@ -721,7 +721,7 @@ ruby-ng_rspec() {
;;
esac
- ${RUBY} -S rspec-${version} ${rspec_params} ${files} || die "rspec failed"
+ ${RUBY} -S rspec-${version} ${rspec_params} ${files} || die -n "rspec failed"
}
# @FUNCTION: ruby-ng_cucumber
@@ -754,7 +754,7 @@ ruby-ng_cucumber() {
;;
esac
- CUCUMBER_PUBLISH_QUIET=true ${RUBY} -S cucumber ${cucumber_params} "$@" || die "cucumber failed"
+ CUCUMBER_PUBLISH_QUIET=true ${RUBY} -S cucumber ${cucumber_params} "$@" || die -n "cucumber failed"
}
# @FUNCTION: ruby-ng_testrb-2