summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch4
-rw-r--r--app-mobilephone/past/past-0.0.4.ebuild17
-rw-r--r--dev-ros/collada_parser/collada_parser-1.12.6.ebuild1
-rw-r--r--dev-ros/collada_parser/collada_parser-9999.ebuild1
-rw-r--r--dev-ros/collada_parser/files/c11.patch13
-rw-r--r--dev-ros/image_cb_detector/files/c11.patch13
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild2
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-9999.ebuild2
-rw-r--r--dev-ros/laser_filters/files/c11.patch36
-rw-r--r--dev-ros/laser_filters/laser_filters-1.8.3.ebuild3
-rw-r--r--eclass/ros-catkin.eclass6
11 files changed, 85 insertions, 13 deletions
diff --git a/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
index d2a82e025688..e04de42b7ef8 100644
--- a/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
+++ b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
@@ -1,5 +1,5 @@
---- src/device.cpp
-+++ src/device.cpp
+--- A/src/device.cpp
++++ B/src/device.cpp
@@ -22,6 +22,7 @@
extern "C" {
diff --git a/app-mobilephone/past/past-0.0.4.ebuild b/app-mobilephone/past/past-0.0.4.ebuild
index 8966954ef363..e1fc18d886d3 100644
--- a/app-mobilephone/past/past-0.0.4.ebuild
+++ b/app-mobilephone/past/past-0.0.4.ebuild
@@ -1,23 +1,26 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
+
inherit cmake-utils
-DESCRIPTION="A simple SMS tool"
-HOMEPAGE="http://www.kde-apps.org/content/show.php/past+-+SMS+Tool?content=74036"
-SRC_URI="http://www.kde-apps.org/CONTENT/content-files/74036-${P}.tar.bz2"
+DESCRIPTION="Simple SMS tool"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/past+-+SMS+Tool?content=74036"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1466626318/74036-${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="dev-qt/qtcore:4
+DEPEND="
+ app-mobilephone/gnokii[sms]
+ dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtgui:4
- app-mobilephone/gnokii[sms]"
+"
RDEPEND="${DEPEND}"
DOCS=( ChangeLog TODO )
diff --git a/dev-ros/collada_parser/collada_parser-1.12.6.ebuild b/dev-ros/collada_parser/collada_parser-1.12.6.ebuild
index ae824f40d4ca..6e7c9dffa7b5 100644
--- a/dev-ros/collada_parser/collada_parser-1.12.6.ebuild
+++ b/dev-ros/collada_parser/collada_parser-1.12.6.ebuild
@@ -24,3 +24,4 @@ RDEPEND="
>=dev-ros/urdf-1.12.6
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/c11.patch" )
diff --git a/dev-ros/collada_parser/collada_parser-9999.ebuild b/dev-ros/collada_parser/collada_parser-9999.ebuild
index ae824f40d4ca..6e7c9dffa7b5 100644
--- a/dev-ros/collada_parser/collada_parser-9999.ebuild
+++ b/dev-ros/collada_parser/collada_parser-9999.ebuild
@@ -24,3 +24,4 @@ RDEPEND="
>=dev-ros/urdf-1.12.6
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/c11.patch" )
diff --git a/dev-ros/collada_parser/files/c11.patch b/dev-ros/collada_parser/files/c11.patch
new file mode 100644
index 000000000000..0fe4eb0c771d
--- /dev/null
+++ b/dev-ros/collada_parser/files/c11.patch
@@ -0,0 +1,13 @@
+Index: collada_parser/src/collada_parser.cpp
+===================================================================
+--- collada_parser.orig/src/collada_parser.cpp
++++ collada_parser/src/collada_parser.cpp
+@@ -67,7 +67,7 @@
+ #include <fcntl.h>
+ #endif
+
+-#define FOREACH(it, v) for(typeof((v).begin())it = (v).begin(); it != (v).end(); (it)++)
++#define FOREACH(it, v) for(auto it = (v).begin(); it != (v).end(); (it)++)
+ #define FOREACHC FOREACH
+
+ namespace ColladaDOM150 { }
diff --git a/dev-ros/image_cb_detector/files/c11.patch b/dev-ros/image_cb_detector/files/c11.patch
new file mode 100644
index 000000000000..bddbce93725f
--- /dev/null
+++ b/dev-ros/image_cb_detector/files/c11.patch
@@ -0,0 +1,13 @@
+Index: image_cb_detector/src/rgbd_cb_detector_action.cpp
+===================================================================
+--- image_cb_detector.orig/src/rgbd_cb_detector_action.cpp
++++ image_cb_detector/src/rgbd_cb_detector_action.cpp
+@@ -143,7 +143,7 @@ public:
+ for(size_t i = 0; i< features.image_points.size(); i++){
+ geometry_msgs::Point pixel = features.image_points[i];
+ float depth = *(depth_ptr+width*(unsigned int)pixel.y+(unsigned int)pixel.x);
+- if ( isnan(depth) )
++ if ( std::isnan(depth) )
+ {
+ continue;
+ }
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
index 972abdce8d2f..59b223affa7d 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
@@ -29,4 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
diff --git a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
index 972abdce8d2f..59b223affa7d 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
@@ -29,4 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
diff --git a/dev-ros/laser_filters/files/c11.patch b/dev-ros/laser_filters/files/c11.patch
new file mode 100644
index 000000000000..11850d48db91
--- /dev/null
+++ b/dev-ros/laser_filters/files/c11.patch
@@ -0,0 +1,36 @@
+commit a185bb6d0b61cbf8283467770e646241f7cac03e
+Author: Mike Purvis <mpurvis@clearpathrobotics.com>
+Date: Fri Jul 15 23:47:45 2016 -0400
+
+ Use std:: namespace for c++11 compat.
+
+diff --git a/include/laser_filters/intensity_filter.h b/include/laser_filters/intensity_filter.h
+index 3f175a0..4c9cfbc 100644
+--- a/include/laser_filters/intensity_filter.h
++++ b/include/laser_filters/intensity_filter.h
+@@ -99,8 +99,8 @@ public:
+ // Calculate histogram
+ if (disp_hist_enabled_){
+ // If intensity value is inf or NaN, skip voting histogram
+- if( isinf((double)filtered_scan.intensities[i]) ||
+- isnan((double)filtered_scan.intensities[i]) )
++ if( std::isinf((double)filtered_scan.intensities[i]) ||
++ std::isnan((double)filtered_scan.intensities[i]) )
+ continue;
+
+ // Choose bucket to vote on histogram,
+diff --git a/test/test_scan_filter_chain.cpp b/test/test_scan_filter_chain.cpp
+index b661f5f..139da60 100644
+--- a/test/test_scan_filter_chain.cpp
++++ b/test/test_scan_filter_chain.cpp
+@@ -60,8 +60,8 @@ sensor_msgs::LaserScan gen_msg(){
+ */
+ void expect_ranges_eq(const std::vector<float> &a, const std::vector<float> &b) {
+ for( int i=0; i<10; i++) {
+- if(isnan(a[i])) {
+- EXPECT_TRUE(isnan(a[i]));
++ if(std::isnan(a[i])) {
++ EXPECT_TRUE(std::isnan(a[i]));
+ }
+ else {
+ EXPECT_NEAR(a[i], b[i], 1e-6);
diff --git a/dev-ros/laser_filters/laser_filters-1.8.3.ebuild b/dev-ros/laser_filters/laser_filters-1.8.3.ebuild
index 4ad356137f53..9d8b33142d1d 100644
--- a/dev-ros/laser_filters/laser_filters-1.8.3.ebuild
+++ b/dev-ros/laser_filters/laser_filters-1.8.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -25,3 +25,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/c11.patch" )
diff --git a/eclass/ros-catkin.eclass b/eclass/ros-catkin.eclass
index 28cf80dba3d2..61d01429b544 100644
--- a/eclass/ros-catkin.eclass
+++ b/eclass/ros-catkin.eclass
@@ -47,7 +47,7 @@ if [ -n "${PYTHON_COMPAT}" ] ; then
PYTHON_ECLASS="python-r1 python-utils-r1"
fi
-inherit ${SCM} ${PYTHON_ECLASS} cmake-utils
+inherit ${SCM} ${PYTHON_ECLASS} cmake-utils flag-o-matic
CATKIN_DO_PYTHON_MULTIBUILD=""
if [ -n "${PYTHON_COMPAT}" ] ; then
@@ -146,6 +146,10 @@ ros-catkin_src_prepare() {
if [ ! -f "${S}/CMakeLists.txt" ] ; then
catkin_init_workspace || die
fi
+
+ # Most packages require C++11 these days. Do it here, in src_prepare so that
+ # ebuilds can override it in src_configure.
+ append-cxxflags '-std=c++11'
}
# @FUNCTION: ros-catkin_src_configure_internal