summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/xpra/files/xpra-1.0.1-cflags-param.patch17
-rw-r--r--x11-wm/xpra/xpra-1.0.1.ebuild3
2 files changed, 19 insertions, 1 deletions
diff --git a/x11-wm/xpra/files/xpra-1.0.1-cflags-param.patch b/x11-wm/xpra/files/xpra-1.0.1-cflags-param.patch
new file mode 100644
index 000000000000..11dbb81ae7bf
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-1.0.1-cflags-param.patch
@@ -0,0 +1,17 @@
+--- xpra-1.0.1/setup.py
++++ xpra-1.0.1/setup.py
+@@ -696,7 +696,14 @@
+ for s in (pkg_config_out, env_cflags, env_ldflags):
+ if not s:
+ continue
++ ahead = False
+ for token in s.split():
++ if token == '--param':
++ ahead = True
++ continue
++ if ahead:
++ ahead = False
++ continue
+ if token[:2] in ignored_flags:
+ pass
+ elif token[:2] in flag_map:
diff --git a/x11-wm/xpra/xpra-1.0.1.ebuild b/x11-wm/xpra/xpra-1.0.1.ebuild
index 6d66ba306c5c..9ec4c53a8c0b 100644
--- a/x11-wm/xpra/xpra-1.0.1.ebuild
+++ b/x11-wm/xpra/xpra-1.0.1.ebuild
@@ -91,7 +91,8 @@ python_prepare_all() {
epatch \
"${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.17.4-deprecated-avcodec.patch
+ "${FILESDIR}"/${PN}-0.17.4-deprecated-avcodec.patch \
+ "${FILESDIR}"/${PN}-1.0.1-cflags-param.patch
if use libav ; then
if ! has_version ">=media-video/libav-9" ; then