summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/empty/Manifest1
-rw-r--r--app-misc/empty/empty-0.6.21b.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/empty/Manifest b/app-misc/empty/Manifest
index 42fdd9d1fa18..b916d68dfed2 100644
--- a/app-misc/empty/Manifest
+++ b/app-misc/empty/Manifest
@@ -1 +1,2 @@
DIST empty-0.6.20b.tgz 16269 BLAKE2B 15a50b2484278cb03b7d91cd5b6a14b9898a3ead3bf2017cc86d9dc8e3a3ec5650b20f57fec6ccdccf780c008841d41205098ea423731c593c1744ca55e5a934 SHA512 bdeda29ecde0bc7ee0432656f0497154e04dbad26aba62a0fe76ded394ddeefe2bfd921594a2dae44459b62ab4767d3b12a7a86216dfda56b6d77035a8b05c3d
+DIST empty-0.6.21b.tgz 26793 BLAKE2B d7266c03ef1580bf9871c294e54e292ba264ef6b72c4be1db8e408696bc8327891cb7827de68e429b0496165bc7e105c697c76f29267b3f10030bc6b183a4910 SHA512 4aef74a61161e8d6b6b5159adfa5b7f2779798fddfdbc070b15ca3f747081eb2f7984b58b0a0cef4452892712d274580cf33c64ffddaee3f70ac9bacfc2f7e09
diff --git a/app-misc/empty/empty-0.6.21b.ebuild b/app-misc/empty/empty-0.6.21b.ebuild
new file mode 100644
index 000000000000..95c42481ff4f
--- /dev/null
+++ b/app-misc/empty/empty-0.6.21b.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small shell utility, similar to expect(1)"
+HOMEPAGE="http://empty.sourceforge.net"
+SRC_URI="https://download.sourceforge.net/empty/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/logger"
+
+PATCHES=( "${FILESDIR}/${PN}-respect-LDFLAGS.patch" )
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin empty
+ doman empty.1
+ dodoc README
+ dodoc -r examples
+}