summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/eutils.eclass32
-rw-r--r--media-libs/urt/files/urt-3.1b-implicit-function-declarations.patch96
-rw-r--r--media-libs/urt/urt-3.1b-r3.ebuild (renamed from media-libs/urt/urt-3.1b-r2.ebuild)3
3 files changed, 117 insertions, 14 deletions
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index 9b4767e1874a..e5d0ebeebb06 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -25,19 +25,6 @@ case ${EAPI:-0} in
;;
esac
-# @FUNCTION: eqawarn
-# @USAGE: [message]
-# @DESCRIPTION:
-# Proxy to ewarn for package managers that don't provide eqawarn and use the PM
-# implementation if available. Reuses PORTAGE_ELOG_CLASSES as set by the dev
-# profile.
-if ! declare -F eqawarn >/dev/null ; then
- eqawarn() {
- has qa ${PORTAGE_ELOG_CLASSES} && ewarn "$@"
- :
- }
-fi
-
# @FUNCTION: emktemp
# @USAGE: [temp dir]
# @DESCRIPTION:
@@ -415,4 +402,23 @@ in_iuse() {
;;
esac
+case ${EAPI:-0} in
+0|1|2|3|4|5|6)
+
+# @FUNCTION: eqawarn
+# @USAGE: [message]
+# @DESCRIPTION:
+# Proxy to ewarn for package managers that don't provide eqawarn and use the PM
+# implementation if available. Reuses PORTAGE_ELOG_CLASSES as set by the dev
+# profile.
+if ! declare -F eqawarn >/dev/null ; then
+ eqawarn() {
+ has qa ${PORTAGE_ELOG_CLASSES} && ewarn "$@"
+ :
+ }
+fi
+
+;;
+esac
+
fi
diff --git a/media-libs/urt/files/urt-3.1b-implicit-function-declarations.patch b/media-libs/urt/files/urt-3.1b-implicit-function-declarations.patch
new file mode 100644
index 000000000000..4e0e31e660b1
--- /dev/null
+++ b/media-libs/urt/files/urt-3.1b-implicit-function-declarations.patch
@@ -0,0 +1,96 @@
+Fix implicit declaration of functions
+
+--- a/cnv/rletoabA62/rletoabA62.c
++++ b/cnv/rletoabA62/rletoabA62.c
+@@ -42,6 +42,10 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <sys/stat.h>
++#include <fcntl.h>
+
+ #ifndef TRUE
+ #define TRUE 1
+--- a/tools/mallocNd.c
++++ b/tools/mallocNd.c
+@@ -67,6 +67,7 @@
+
+ /* Imports */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ /* Forward declarations */
+--- a/get/getx11/getx11.h
++++ b/get/getx11/getx11.h
+@@ -29,6 +29,8 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <ctype.h>
++#include <unistd.h>
++#include <X11/Xlibint.h>
+ #include <X11/X.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+--- a/tools/into.c
++++ b/tools/into.c
+@@ -27,6 +27,7 @@
+
+ #include "rle_config.h"
+ #include <stdio.h>
++#include <unistd.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/param.h> /* for MAXPATHLEN */
+--- a/tools/rlecat.c
++++ b/tools/rlecat.c
+@@ -15,6 +15,7 @@
+ */
+
+ #include <stdio.h>
++#include <unistd.h>
+ #include "rle.h"
+ #include "rle_raw.h"
+
+--- a/tools/rleaddcom.c
++++ b/tools/rleaddcom.c
+@@ -26,6 +26,7 @@
+ */
+
+ #include <stdio.h>
++#include <unistd.h>
+ #include "rle.h"
+ #include <sys/types.h>
+ #include <sys/param.h> /* for MAXPATHLEN */
+--- a/tools/rlenoise.c
++++ b/tools/rlenoise.c
+@@ -20,6 +20,7 @@
+ */
+
+ #include <stdio.h>
++#include <time.h>
+ #include "rle.h"
+
+ /* Change this according the value on your system. This is a crock. */
+--- a/cnv/rletorla.c
++++ b/cnv/rletorla.c
+@@ -29,6 +29,7 @@
+ * System includes.
+ */
+ #include <stdio.h>
++#include <unistd.h>
+ #include "rlb_header.h"
+ #include "rle.h"
+
+--- a/cnv/giftorle.c
++++ b/cnv/giftorle.c
+@@ -22,6 +22,7 @@
+ /* +------------------------------------------------------------------+ */
+
+ #include <stdio.h>
++#include <unistd.h>
+ #include "rle.h"
+
+ #ifndef lint
diff --git a/media-libs/urt/urt-3.1b-r2.ebuild b/media-libs/urt/urt-3.1b-r3.ebuild
index 9630f407797e..c22b164afab3 100644
--- a/media-libs/urt/urt-3.1b-r2.ebuild
+++ b/media-libs/urt/urt-3.1b-r3.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.cs.utah.edu/gdc/projects/urt/"
SRC_URI="ftp://ftp.iastate.edu/pub/utah-raster/${P}.tar.Z"
LICENSE="URT gif? ( free-noncomm )"
-SLOT="0/${PVR}"
+SLOT="0/3.1b-r2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="gif postscript static-libs tiff X"
@@ -37,6 +37,7 @@ PATCHES=(
"${FILESDIR}"/${P}-make.patch
"${FILESDIR}"/${P}-solaris.patch
"${FILESDIR}"/${P}-librle-toolchain.patch
+ "${FILESDIR}"/${P}-implicit-function-declarations.patch
)
src_prepare() {