summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/logstash-bin/Manifest2
-rw-r--r--app-admin/logstash-bin/logstash-bin-7.17.1.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index 185b32e15b9f..40e691639389 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -1,4 +1,6 @@
DIST logstash-6.8.23.tar.gz 178007697 BLAKE2B d7ba85a141586b8ee6cf524b9ab39b6b9a0777df5357fb22f15770126023599d7b62eeafc55dc87e0ff401b5df8dab9084a9ea4ba98c850e2ee98d4988bf4ad2 SHA512 3ee0de55cca50c1ea5b8afbc618783c7e301ebdc570c34d590160468b0b7708afe83589669c08106ac006e64436903ccbb3b3322e2801332b921ea802a788d86
DIST logstash-7.16.3-linux-x86_64.tar.gz 364791274 BLAKE2B 12e9944dce3e270358ef02d292655171911774a2351bf7c0a4f9aaf6206db31c4b1b114fee24c39fa72d9e10f31e5a6ad56f42dd8a25278c28cec6c2ab52a1b7 SHA512 fd9bc03c4dd58853075cd4d179a613cc24fde22a5decc943197002dc5cda9d03ece716e766084fd3d293293f4de88866264f5bd7e96ffd3d541c555b4264782d
+DIST logstash-7.17.1-linux-x86_64.tar.gz 364323385 BLAKE2B 24a4c94ee048918907fa05ee91a7c7449f7f38ca3662c99f614b71391b02804b86a8272f9d8225b76f143b80d2aeca0a82d9da64b75b1e273df67afb21f62aad SHA512 b61947c17d5871563f0d4583fa113d9804f4f4b674d011110ce515bce3630577e519694a660fd0d91f4041bd22a7994de2606124156fd878b0f2ebcd2ece2c7f
DIST logstash-oss-6.8.23.tar.gz 177876480 BLAKE2B d961c9073c1108b3a0e74ba763e0ce45b35a5767cd732e7ec756697c5f1526e01b23c0919acefa173b5410e9a4908920a24c1ce351dd7c09d998cb025ba05aef SHA512 87488767c6239878c1383c1f28ca17e8f330c10298542627c0c44a0620976737a1acbca55b8db6b6917d8b8bcb988ec4d84b2a840a4ef6362909b7e230a0e0b6
DIST logstash-oss-7.16.3-linux-x86_64.tar.gz 364597354 BLAKE2B 9ddda512913491cc178fccc513d9a26298dda62169db8e8e1c61d6c37ad4af08b1cc152d978f8b353030d9366a07e53acc4596162ab5f7f5e57060d953d99c97 SHA512 b49ed0923ac202e406919758fbeadf1169492ff3d60adad6dba5e2eb3de08344b1e060d6efa2161c1653636bf51f7f8f877992f0d2cd06c5d35d7323f84dadbc
+DIST logstash-oss-7.17.1-linux-x86_64.tar.gz 364126005 BLAKE2B bfa86f4babb4c987bb78a75b96543a858d02939b2c4b3b92dfd2e46d117775f08fadee2743e88878ebc0fefb8be70f23c269fd2cbd3f28808e7f4bd7e430bbc4 SHA512 4d3a2cb1c404795c83486c993945a9c8d60cb5f6d351c7f7c3c277ec6f82181ae5980231cf3582a01ac5a2f85ba577bd11f576f2a283054966eddcb0b82e4cbf
diff --git a/app-admin/logstash-bin/logstash-bin-7.17.1.ebuild b/app-admin/logstash-bin/logstash-bin-7.17.1.ebuild
new file mode 100644
index 000000000000..ddceca40f83c
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-7.17.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz )
+ !x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_PN}-oss-${PV}-linux-x86_64.tar.gz )"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT x-pack? ( Elastic )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="x-pack"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="acct-group/logstash
+ acct-user/logstash
+ virtual/jre"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ local d
+ for d in aarch64-FreeBSD aarch64-Linux arm-Linux Darwin i386-Linux i386-SunOS \
+ i386-Windows mips64el-Linux ppc64-AIX ppc64le-Linux ppc64-Linux \
+ ppc-AIX s390x-Linux sparcv9-Linux sparcv9-SunOS x86_64-DragonFlyBSD \
+ x86_64-FreeBSD x86_64-OpenBSD x86_64-SunOS x86_64-Windows; do
+ rm -r vendor/jruby/lib/jni/$d || die
+ done
+
+ # remove bundled java
+ rm -r jdk || die
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/{pipelines.yml,startup.options} || die
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ doins "${FILESDIR}/pipelines.yml"
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r2" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r2" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ elog
+ elog "Installing plugins:"
+ elog "eselect logstash-plugin install logstash-output-gelf"
+ elog
+
+ elog "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ elog
+ elog "Sample configuration:"
+ elog "${EROOT}/usr/share/${MY_PN}"
+ elog
+ elog "The default pipeline configuration expects the configuration(s) to be found in:"
+ elog "${EROOT}/etc/logstash/conf.d/*.conf"
+}