summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flask/Manifest3
-rw-r--r--dev-python/flask/files/flask-0.10.1-is_package.patch13
-rw-r--r--dev-python/flask/files/flask-0.10.1-sort_json.patch54
-rw-r--r--dev-python/flask/files/flask-0.10.1-test_appcontext.patch14
-rw-r--r--dev-python/flask/flask-0.10.1-r1.ebuild42
-rw-r--r--dev-python/flask/flask-0.12.1.ebuild59
-rw-r--r--dev-python/flask/flask-0.12.ebuild54
7 files changed, 0 insertions, 239 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index c1af8385923b..27d6d17b9fac 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,4 +1 @@
-DIST Flask-0.10.1.tar.gz 544247 BLAKE2B 986142e0a9e4668af462e211d7189114a8e75ec0bd433de9870c2fb1578ec3c565acdc0e724a1ea2eb88134323f53a5e774d266c8b15a7471734ec1c41a023f5 SHA512 0008d62d03a46b071c7d0510513d011a9bfd2b77df7f677371a446ca9805d16b1ee5e17dd8dd7cde6443a629370234e44735e20381de20a7da385969797f053f
-DIST Flask-0.12.1.tar.gz 548511 BLAKE2B 4e67a397b48387561bce5a2fcfe503018ef6bf9ff29fd766fee4330a706e06927036251d9aff22f6a4bcf83ffe56e4eaa24b366c7ce91e51f36c460dbf2483b3 SHA512 23a376ed452bbf874eeeff959924bf8aee51fc9196af71092a7a457742a635fb3adaa958e61625522e93a14092e3bb88a22a74ef419513ca1ae93a1d08723ac5
DIST Flask-0.12.2.tar.gz 548510 BLAKE2B bd92d0e7e6ff36d371ffd958708517d16e41d1475af9153bf3d5234c33aa5c0ab415cbd254b711731cf8cffddac94b475f62d9fff2f9fe756b0fa30bb36d4343 SHA512 c00bb807e8fbc943e23a3721acf5b04320e7a58d658bca46bdf83a345b4c4d5729accae338505e134f01bc908adec9555fd94e8c87ef6f0367e6037215c06319
-DIST Flask-0.12.tar.gz 531923 BLAKE2B 022ac42d56ab811346de05a4eed90c8a212694ae35e293889d7338377001ccedb7e0e6461a4aa6df6721ce4245086cac64fe52bf5439278c17f59c911e6ad4dd SHA512 b8e9e005a850fcba413ad151998768ea0facb68f05855a1934cc6e4de1438cb59a4dd1bc74d2b04d52b3e837afa0a7785e98ae6c5af363a894c2be64773113f0
diff --git a/dev-python/flask/files/flask-0.10.1-is_package.patch b/dev-python/flask/files/flask-0.10.1-is_package.patch
deleted file mode 100644
index 611d931d502f..000000000000
--- a/dev-python/flask/files/flask-0.10.1-is_package.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://github.com/mitsuhiko/flask/issues/487
-diff -ur Flask-0.10.1.orig/flask/helpers.py Flask-0.10.1/flask/helpers.py
---- flask/helpers.py 2013-06-14 06:35:43.000000000 +0800
-+++ flask/helpers.py 2013-08-16 16:18:36.194006290 +0800
-@@ -679,7 +679,7 @@
- filename = sys.modules[import_name].__file__
- package_path = os.path.abspath(os.path.dirname(filename))
- # package_path ends with __init__.py for a package
-- if loader.is_package(root_mod_name):
-+ if package_path.endswith('__init__.py'):
- package_path = os.path.dirname(package_path)
-
- site_parent, site_folder = os.path.split(package_path)
diff --git a/dev-python/flask/files/flask-0.10.1-sort_json.patch b/dev-python/flask/files/flask-0.10.1-sort_json.patch
deleted file mode 100644
index e78cd0dee825..000000000000
--- a/dev-python/flask/files/flask-0.10.1-sort_json.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-https://github.com/mitsuhiko/flask/commit/a2bc61b5ab19e899735f8945f68123b4cea570d5
-diff --git a/flask/testsuite/helpers.py b/flask/testsuite/helpers.py
-index 636f67f..7de70c0 100644
---- a/flask/testsuite/helpers.py
-+++ b/flask/testsuite/helpers.py
-@@ -173,7 +173,33 @@ def index():
- c = app.test_client()
- rv = c.get('/')
- lines = [x.strip() for x in rv.data.strip().decode('utf-8').splitlines()]
-- self.assert_equal(lines, [
-+ sorted_by_str = [
-+ '{',
-+ '"values": {',
-+ '"0": "foo",',
-+ '"1": "foo",',
-+ '"10": "foo",',
-+ '"11": "foo",',
-+ '"12": "foo",',
-+ '"13": "foo",',
-+ '"14": "foo",',
-+ '"15": "foo",',
-+ '"16": "foo",',
-+ '"17": "foo",',
-+ '"18": "foo",',
-+ '"19": "foo",',
-+ '"2": "foo",',
-+ '"3": "foo",',
-+ '"4": "foo",',
-+ '"5": "foo",',
-+ '"6": "foo",',
-+ '"7": "foo",',
-+ '"8": "foo",',
-+ '"9": "foo"',
-+ '}',
-+ '}'
-+ ]
-+ sorted_by_int = [
- '{',
- '"values": {',
- '"0": "foo",',
-@@ -198,8 +224,12 @@ def index():
- '"19": "foo"',
- '}',
- '}'
-- ])
-+ ]
-
-+ try:
-+ self.assert_equal(lines, sorted_by_int)
-+ except AssertionError:
-+ self.assert_equal(lines, sorted_by_str)
-
- class SendfileTestCase(FlaskTestCase):
-
diff --git a/dev-python/flask/files/flask-0.10.1-test_appcontext.patch b/dev-python/flask/files/flask-0.10.1-test_appcontext.patch
deleted file mode 100644
index 11dee7a9f6bf..000000000000
--- a/dev-python/flask/files/flask-0.10.1-test_appcontext.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://github.com/mitsuhiko/flask/commit/f88cc2d2f9d14d97e33ddd2bbaa4b1885db06e1c.
-diff --git a/flask/testsuite/signals.py b/flask/testsuite/signals.py
-index e061932..45ca45d 100644
---- a/flask/testsuite/signals.py
-+++ b/flask/testsuite/signals.py
-@@ -102,7 +102,7 @@ def test_appcontext_signals(self):
- def record_push(sender, **kwargs):
- recorded.append('push')
- def record_pop(sender, **kwargs):
-- recorded.append('push')
-+ recorded.append('pop')
-
- @app.route('/')
- def index():
diff --git a/dev-python/flask/flask-0.10.1-r1.ebuild b/dev-python/flask/flask-0.10.1-r1.ebuild
deleted file mode 100644
index 931a2015563a..000000000000
--- a/dev-python/flask/flask-0.10.1-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://github.com/mitsuhiko/flask/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-# Usual; test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${P}-is_package.patch
- "${FILESDIR}"/${P}-sort_json.patch
- "${FILESDIR}"/${P}-test_appcontext.patch )
-
-python_test() {
- "${PYTHON}" run-tests.py || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-0.12.1.ebuild b/dev-python/flask/flask-0.12.1.ebuild
deleted file mode 100644
index 851f950e42f4..000000000000
--- a/dev-python/flask/flask-0.12.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://github.com/pallets/flask/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/click-2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
- # DeprecationWarning: Flags not at the start of the expression
- sed -e "s/r'\(.*\)\((?.*)\)'/r'\2\1'/" -i tests/test_basic.py || die
- # issubclass(ModuleNotFoundError, ImportError)
- sed -e 's/\(excinfo.type\) is \(ImportError\)/issubclass(\1, \2)/' \
- -i tests/test_ext.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- use doc && HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-0.12.ebuild b/dev-python/flask/flask-0.12.ebuild
deleted file mode 100644
index 74cc21a5a81e..000000000000
--- a/dev-python/flask/flask-0.12.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://github.com/pallets/flask/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/click-2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- use doc && HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}