summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/boreas/Manifest1
-rw-r--r--net-analyzer/boreas/boreas-22.5.0.ebuild45
-rw-r--r--net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch14
-rw-r--r--net-analyzer/boreas/metadata.xml20
-rw-r--r--profiles/features/musl/package.mask1
5 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/boreas/Manifest b/net-analyzer/boreas/Manifest
new file mode 100644
index 000000000000..54b0c2bce386
--- /dev/null
+++ b/net-analyzer/boreas/Manifest
@@ -0,0 +1 @@
+DIST boreas-22.5.0.tar.gz 128205 BLAKE2B eea2c1bc488c4d54cd678d081846b76789de225daffcd4157ff7b33e6286fcbf7cf6e7961cbfa53f8d849f50da2c12e0c97e44439861c4cb7d79eb8f047a36bc SHA512 46b4982b20e02826296da56415fac0ddfa2703e9154c46352a6140eedf62c57eb14a4d7423c6f2d6e38eef764b36e975aa03cd38987a1664978092dcaddbe7fc
diff --git a/net-analyzer/boreas/boreas-22.5.0.ebuild b/net-analyzer/boreas/boreas-22.5.0.ebuild
new file mode 100644
index 000000000000..fa6b7b370f6d
--- /dev/null
+++ b/net-analyzer/boreas/boreas-22.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Greenbone Scanner for alive hosts"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/boreas"
+SRC_URI="https://github.com/greenbone/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=net-analyzer/gvm-libs-22.4.1
+ net-libs/libpcap
+"
+
+BDEPEND="
+ doc? (
+ app-text/doxygen
+ app-text/xmltoman
+ )
+ test? ( dev-libs/cgreen )
+"
+
+PATCHES=(
+ # Fix cmake error https://cmake.org/cmake/help/latest/policy/CMP0004.html
+ # PR upstream: https://github.com/greenbone/boreas/pull/66
+ "${FILESDIR}"/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLOCALSTATEDIR=${EPREFIX}/var"
+ "-DSYSCONFDIR=${EPREFIX}/etc"
+ "-DBINDIR=${EPREFIX}/usr/bin"
+ )
+ cmake_src_configure
+}
diff --git a/net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch b/net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch
new file mode 100644
index 000000000000..9196531765fe
--- /dev/null
+++ b/net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch
@@ -0,0 +1,14 @@
+Fixes leading withespaces in LDFLAGS for libpcap
+From: Giuseppe Foti <foti.giuseppe@gmail.com>
+Upstream PR: https://github.com/greenbone/boreas/pull/66
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -32,6 +32,7 @@ if (PCAP_CONFIG)
+ execute_process (COMMAND pcap-config --libs
+ OUTPUT_VARIABLE PCAP_LDFLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
++ string(STRIP ${PCAP_LDFLAGS} PCAP_LDFLAGS)
+ execute_process (COMMAND pcap-config --cflags
+ OUTPUT_VARIABLE PCAP_CFLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
diff --git a/net-analyzer/boreas/metadata.xml b/net-analyzer/boreas/metadata.xml
new file mode 100644
index 000000000000..4ef252b3f88b
--- /dev/null
+++ b/net-analyzer/boreas/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>foti.giuseppe@gmail.com</email>
+ <name>Giuseppe Foti</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Boreas is a command line tool to scan for alive hosts. It supports IPv4 and IPv6 address ranges and allows to exclude certain addresses from a range.
+ The alive ping tests support ICMP, TCP-ACK, TCP-SYN and ARP and any combination.
+ For TCP ping an individual port list can be applied.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">greenbone/boreas</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/profiles/features/musl/package.mask b/profiles/features/musl/package.mask
index c906a8c9b5c0..a31c6934656d 100644
--- a/profiles/features/musl/package.mask
+++ b/profiles/features/musl/package.mask
@@ -132,6 +132,7 @@ sys-apps/noexec
dev-db/pg-gvm
net-analyzer/notus-scanner
net-analyzer/greenbone-feed-sync
+net-analyzer/boreas
# Petr Vaněk <arkamar@atlas.cz> (2022-09-23)
# Musl does not implement rresvport function, bugs #713810 and #713376.