summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/connection_pool/Manifest1
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.4.0.ebuild29
-rw-r--r--dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild4
-rw-r--r--dev-ruby/fiber-local/fiber-local-1.0.0.ebuild4
-rw-r--r--dev-ruby/hocon/Manifest1
-rw-r--r--dev-ruby/hocon/hocon-1.4.0.ebuild24
-rw-r--r--dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16-r1.ebuild40
-rw-r--r--dev-ruby/rspec-files/rspec-files-1.1.3.ebuild4
-rw-r--r--dev-ruby/rspec-memory/rspec-memory-1.0.3.ebuild4
-rw-r--r--dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild23
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild41
-rw-r--r--dev-ruby/ruby_engine/ruby_engine-2.0.0.ebuild4
-rw-r--r--dev-ruby/ruby_version/ruby_version-1.0.2.ebuild4
-rw-r--r--dev-ruby/timers/Manifest1
-rw-r--r--dev-ruby/timers/metadata.xml3
-rw-r--r--dev-ruby/timers/timers-4.3.5.ebuild29
-rw-r--r--eclass/ruby-fakegem.eclass12
-rw-r--r--eclass/ruby-ng.eclass25
19 files changed, 241 insertions, 13 deletions
diff --git a/dev-ruby/connection_pool/Manifest b/dev-ruby/connection_pool/Manifest
index 3e6955376efe..27e4ac7a4de7 100644
--- a/dev-ruby/connection_pool/Manifest
+++ b/dev-ruby/connection_pool/Manifest
@@ -1,2 +1,3 @@
DIST connection_pool-2.2.5.gem 14848 BLAKE2B d3e21e5d3c330fb501e9890260c0fed003f3c8afc6a9106c139f77e879c45232de1cbc16be6088c757a1204f3c64b0797010fddc0d1c9cf555389348b6f61152 SHA512 3bc4e4d241cd4b1adb00d341aafe7795bbf0eff459ace962670d83c20c0eaa0d42f49a1f5e61c2327ff4fcbf3abfbc6f6c910f7a31d4a0f62bc55c782ab20e45
DIST connection_pool-2.3.0.tar.gz 10656 BLAKE2B 235ddcf6956c53bff276c27b47f3dd21f008cad4eea07692cad186117e6d6a986acb1fa1e2eeb29a9bb72f5ee5e3b7c80927e711ebdf00ceec9af2f02ca37e25 SHA512 8f9c9c1c738b5321b52c28033bb7ac8f6697edfe584f858ce4891514c65730ccb950db9136f059991c4fe1d1386b18883d7b61557aeeb687c602a09229dcb38f
+DIST connection_pool-2.4.0.tar.gz 11243 BLAKE2B b8fcb164473863dfa4d4cd0a2f511f006ab0369a3890639115b42755eb6a50f1e8e37e1b2bdba0a4ac203ef05e5fde84cc95b0f10f547b56effbaa19df0ee64e SHA512 7b3d732da657ecdd1ebe2fa1600c0d723496be9c89397db3da06d854daba07aa959750527ec2c08bdf5a41e30df2ee04407fe76260440848db9b426c508a3544
diff --git a/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild b/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild
new file mode 100644
index 000000000000..dbb4aafbffa5
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_GEMSPEC="connection_pool.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+SRC_URI="https://github.com/mperham/connection_pool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}
diff --git a/dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild b/dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild
index 7ae0b3d67ba3..1ffb33df0bfe 100644
--- a/dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild
+++ b/dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
diff --git a/dev-ruby/fiber-local/fiber-local-1.0.0.ebuild b/dev-ruby/fiber-local/fiber-local-1.0.0.ebuild
index 6d9a310dfb73..4109ddf8b253 100644
--- a/dev-ruby/fiber-local/fiber-local-1.0.0.ebuild
+++ b/dev-ruby/fiber-local/fiber-local-1.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.md"
diff --git a/dev-ruby/hocon/Manifest b/dev-ruby/hocon/Manifest
index 1e95dce65ed2..a054377a285f 100644
--- a/dev-ruby/hocon/Manifest
+++ b/dev-ruby/hocon/Manifest
@@ -1 +1,2 @@
DIST hocon-1.3.1.tar.gz 146330 BLAKE2B 4eaa791f148347cf30cea04c79ed63fbc804a0ef7f4bdf1640da706f857a46a99342d338a8444b2df316ef972e11d5a3e10aae8d82f464b2964aa30c2086274c SHA512 c73cfd8d6c77751d1d2a35d85cad2f2eef700a01e8b8de9449c0c9dfefe8d4a80c4a79dd3db8ee4a6d2c3649f26d6780cbe05fe9b067de05ee3711b00faf4255
+DIST hocon-1.4.0.tar.gz 147184 BLAKE2B 7a072b2c4e5bc0dda80b836a6b905888e2a8cf6da87403c738f62ffebc9bae6dfa71125c68f90c4b2608a36f1491f17ceb55b4628e54b44b8acb3933c2a748a9 SHA512 735cd6344d96e5e5e42a94da875476483c6cb993c9d2f6c144b74713e1eb5cbdadcd8a2c73414d456ff9fa565a6dcc575507ee1a6df339ffe1c1944ed6d15e33
diff --git a/dev-ruby/hocon/hocon-1.4.0.ebuild b/dev-ruby/hocon/hocon-1.4.0.ebuild
new file mode 100644
index 000000000000..993b80b25b9d
--- /dev/null
+++ b/dev-ruby/hocon/hocon-1.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="hocon"
+
+RUBY_FAKEGEM_GEMSPEC="hocon.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is a port of the Typesafe Config library to Ruby"
+HOMEPAGE="https://github.com/puppetlabs/ruby-hocon"
+SRC_URI="https://github.com/puppetlabs/ruby-hocon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-hocon-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
diff --git a/dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16-r1.ebuild b/dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16-r1.ebuild
new file mode 100644
index 000000000000..9c04a8628ae6
--- /dev/null
+++ b/dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md HISTORY.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+# rspec tests have dependencies not packaged in Gentoo at this time:
+# puppetlabs_spec_helper
+# CFPropertyList
+# simplecov-console
+# spec-puppet
+# rubocop
+# rubocop-rspec
+# license_finder
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This library provides a simple way to write new native resources for puppet."
+HOMEPAGE="https://rubygems.org/gems/puppet-resource_api https://github.com/puppetlabs/puppet-resource_api"
+LICENSE="MIT"
+# 2023/03/19: .gem does not contain specfiles, and lags behind GitHub releases.
+SRC_URI="https://github.com/puppetlabs/puppet-resource_api/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # the gemspec tries to system(git ls-files) but has a meaningful fallback, so just make it not run git.
+ sed -i -e '/git --help/s,git,false git,g' \
+ "${RUBY_FAKEGEM_GEMSPEC}" \
+ || die
+}
+
+ruby_add_rdepend ">=dev-ruby/hocon-1.0"
diff --git a/dev-ruby/rspec-files/rspec-files-1.1.3.ebuild b/dev-ruby/rspec-files/rspec-files-1.1.3.ebuild
index 82b5871dbb33..5ea1e49458df 100644
--- a/dev-ruby/rspec-files/rspec-files-1.1.3.ebuild
+++ b/dev-ruby/rspec-files/rspec-files-1.1.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="readme.md"
diff --git a/dev-ruby/rspec-memory/rspec-memory-1.0.3.ebuild b/dev-ruby/rspec-memory/rspec-memory-1.0.3.ebuild
index 5fede3288c8e..432713552ad0 100644
--- a/dev-ruby/rspec-memory/rspec-memory-1.0.3.ebuild
+++ b/dev-ruby/rspec-memory/rspec-memory-1.0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.md"
diff --git a/dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild b/dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..297d99c991d8
--- /dev/null
+++ b/dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+# Gem does not contain tests and upstream releases are not tagged
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Stub environment variables in a scoped context for testing"
+HOMEPAGE="https://github.com/pboling/rspec-stubbed_env"
+IUSE=""
+SLOT="1"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.0"
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index d5385b0f5daf..4ab9900fe33e 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,2 +1,3 @@
DIST ruby-prof-1.4.4.tgz 232833 BLAKE2B 932f5edd47a9de57f4c394044d1d563935f456b3cf77ac85c912359e34c8c1becafddfda329e05a672d4009b81fba386f76ba4677cee2dde44f40bef5abcaa94 SHA512 5ae25b32b26cfe7faf60c0ba84d3853c74f272783a8dde858ce3de0186683c7cf35dbcb5e89b1e5aa742ee93ea601e55f7ad99491bf9c1a1accef454b08b9921
DIST ruby-prof-1.4.5.tgz 233733 BLAKE2B 1285eb2862a9159a80ead9c3e26f372ec00719553f8bc42d10645e7ea86bfb1f27525c1bdbb3a4ae187a0a34ac7d11c7516b594070fce694d1f29e840710d500 SHA512 444af657b5aff9b8c18e15600cb1bc89a2fb9085a56ac65ca392614234bdce73445fcf41ea638f1a2f02826ef35288896befd5e74526b5fa3b93d63eeb3700a0
+DIST ruby-prof-1.6.1.tgz 243127 BLAKE2B acceb23b137d080983e0dc8f431b8b31be05db16e8820c478cc7c33f3b578e243ecb536baacbb36e4fbd4675e99f567d3c68a70f09929b3cdd6c10f21413b59b SHA512 01e85e12e2185e092ee10953239b4253da4970162e53563f5270d1b09a6b6a4606b2d15b7c97cb70b3254e3657e6874a22a1873ee28f3c62d04d066f938434a8
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild
new file mode 100644
index 000000000000..39c10f52a3d8
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_prof/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/ruby_engine/ruby_engine-2.0.0.ebuild b/dev-ruby/ruby_engine/ruby_engine-2.0.0.ebuild
index 5bc191280447..2fbf6b5a1043 100644
--- a/dev-ruby/ruby_engine/ruby_engine-2.0.0.ebuild
+++ b/dev-ruby/ruby_engine/ruby_engine-2.0.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/ruby_version/ruby_version-1.0.2.ebuild b/dev-ruby/ruby_version/ruby_version-1.0.2.ebuild
index 9dc7c8d18959..3f6d511a0673 100644
--- a/dev-ruby/ruby_version/ruby_version-1.0.2.ebuild
+++ b/dev-ruby/ruby_version/ruby_version-1.0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/timers/Manifest b/dev-ruby/timers/Manifest
index 758f93e50a2c..b33d269e6bde 100644
--- a/dev-ruby/timers/Manifest
+++ b/dev-ruby/timers/Manifest
@@ -1 +1,2 @@
DIST timers-4.3.3.tar.gz 12928 BLAKE2B af64b44116565a8cb6b68349de6a46e8b67d22508e16e204af104ed7a59cc1db1dae0c36917ccde1932c33e53d9d71fc57cb317570cc24aaee82531ce178f37c SHA512 4a715e4a786f98ec429a250de53cfa67bed6b5a99b6298c21251e6dcf1315f1185d8c45bea01025832046381ebac462cd35415f7573d58c55c30b47c2567d4bf
+DIST timers-4.3.5.tar.gz 15651 BLAKE2B 2dc34bb23a4971c673aff5120502714035fe31aed34854b5f7beb744ca46ad704b88d1403ad594ea49f71bb709db7942ed521d237e2477fe2e9d41cc3cd2b538 SHA512 fa5a25eda15628f5a17cd2e7acc4eb2819a766de7ffdba03d425a93cb3229f0f7b8083e9990b5308e65c2d8aab396e33dd4d152252888eff1cc0039cac6a5e46
diff --git a/dev-ruby/timers/metadata.xml b/dev-ruby/timers/metadata.xml
index e299236a3f68..b93a94607cde 100644
--- a/dev-ruby/timers/metadata.xml
+++ b/dev-ruby/timers/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Ruby Project</name>
</maintainer>
<upstream>
- <remote-id type="github">tarcieri/timers</remote-id>
+ <remote-id type="github">socketry/timers</remote-id>
+ <remote-id type="rubygems">timers</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ruby/timers/timers-4.3.5.ebuild b/dev-ruby/timers/timers-4.3.5.ebuild
new file mode 100644
index 000000000000..61acdda238e4
--- /dev/null
+++ b/dev-ruby/timers/timers-4.3.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="timers.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby one-shot and periodic timers"
+HOMEPAGE="https://github.com/socketry/timers"
+SRC_URI="https://github.com/socketry/timers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid performance-based tests since we cannot guarantee specific performance levels.
+ rm -f test/timers/performance.rb || die
+}
diff --git a/eclass/ruby-fakegem.eclass b/eclass/ruby-fakegem.eclass
index 9ef5e1f098d1..4ad1d8eca683 100644
--- a/eclass/ruby-fakegem.eclass
+++ b/eclass/ruby-fakegem.eclass
@@ -44,6 +44,7 @@ RUBY_FAKEGEM_TASK_DOC="${RUBY_FAKEGEM_TASK_DOC-rdoc}"
# - rspec3 (calls ruby-ng_rspec, adds dev-ruby/rspec:3 to the dependencies)
# - cucumber (calls ruby-ng_cucumber, adds dev-util/cucumber to the
# dependencies)
+# - sus (calls ruby-ng_sus, adds dev-ruby/sus to the dependencies)
# - none
RUBY_FAKEGEM_RECIPE_TEST="${RUBY_FAKEGEM_RECIPE_TEST-rake}"
@@ -193,7 +194,15 @@ case ${RUBY_FAKEGEM_RECIPE_TEST} in
RESTRICT+=" !test? ( test )"
ruby_add_bdepend "test? ( dev-util/cucumber )"
;;
+ sus)
+ IUSE+=" test"
+ RESTRICT+=" !test? ( test )"
+ ruby_add_bdepend "test? ( dev-ruby/sus )"
+ ;;
+ none)
+ ;;
*)
+ eqawarn "Unknown test recipe '${RUBY_FAKEGEM_RECIPE_TEST}' specified, using 'none'"
RUBY_FAKEGEM_RECIPE_TEST="none"
;;
esac
@@ -563,6 +572,9 @@ each_fakegem_test() {
cucumber)
ruby-ng_cucumber
;;
+ sus)
+ ruby-ng_sus
+ ;;
none)
ewarn "each_fakegem_test called, but \${RUBY_FAKEGEM_RECIPE_TEST} is 'none'"
;;
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index f85a933f81d9..c273a431c5b1 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -757,6 +757,31 @@ ruby-ng_cucumber() {
CUCUMBER_PUBLISH_QUIET=true ${RUBY} -S cucumber ${cucumber_params} "$@" || die -n "cucumber failed"
}
+# @FUNCTION: ruby-ng_sus
+# @DESCRIPTION:
+# This is simply a wrapper around the sus-parallel command (executed by $RUBY})
+# which also respects TEST_VERBOSE and NOCOLOR environment variables.
+ruby-ng_sus() {
+ debug-print-function ${FUNCNAME} "${@}"
+
+ if [[ "${DEPEND}${BDEPEND}" != *"dev-ruby/sus"* ]]; then
+ ewarn "Missing test dependency dev-ruby/sus"
+ fi
+
+ local sus_params=
+
+ # sus has a --verbose argument but it does not seem to impact the output (yet?)
+ case ${TEST_VERBOSE} in
+ 1|yes|true)
+ sus_params+=" --verbose"
+ ;;
+ *)
+ ;;
+ esac
+
+ ${RUBY} -S sus-parallel ${sus_params} "$@" || die -n "sus failed"
+}
+
# @FUNCTION: ruby-ng_testrb-2
# @DESCRIPTION:
# This is simply a replacement for the testrb command that load the test