summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-23.04.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 74e9684ce2a2..a920ab520aba 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1,2 +1,3 @@
DIST kopeninghours-22.12.3.tar.xz 71072 BLAKE2B f86ca120035da5eb01736ea6dd5e35ed6f961a0d5cfe7af4b8d13b4a00b80b3252a39996efdb039a10a1e5d44fc33a57133ac5c75444d866e5f8a6c2e778e2ed SHA512 c8f87eb7398f8aff8de74b86dbc33fd50d90485dca4fb1e8bd87d4d697bb9f3670bca7ab11baf47ce5186fcb7067ae74efdbd20896d5a4e0b84c15edafd31dce
DIST kopeninghours-23.04.1.tar.xz 71740 BLAKE2B 828c40d09464673d3098cc01d582300a78baaf0fd223320e8c9609514278a2a1358d07e7dc7bb742826cf06a8e7d27ec1964a9d5cee363cc9b67d1dbb6eeaf14 SHA512 02cd56c313510a6fd44b7d3feeca9ef2a56004bc30cab555c5c388afb0176de52176e4bccdb718388ee05773132dd05e30b54cf770f7c4a7df4318782eddee67
+DIST kopeninghours-23.04.2.tar.xz 71768 BLAKE2B 2ddcead9c00adbb210adea3affd44656b0fe7e0f0b496f78308291530a5fa56a06728b3977a861d4c605cfa1e592038772cb0f3b39b0e8d538aa87549b2ae9d5 SHA512 5378b23c12c9037512153630a643fe3ad0514e4e2113af59495ef1f323e46ba2fee7866f6f4f5325703ab5134c49948ebda46c491a1fbddc7fcb3e1bfd7593e3
diff --git a/dev-libs/kopeninghours/kopeninghours-23.04.2.ebuild b/dev-libs/kopeninghours/kopeninghours-23.04.2.ebuild
new file mode 100644
index 000000000000..14890beac8eb
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-23.04.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+PYTHON_COMPAT=( python3_{10..11} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}