summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/libb2/libb2-0.98.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-crypt/libb2/libb2-0.98.1.ebuild b/app-crypt/libb2/libb2-0.98.1.ebuild
index 1f7105ca4785..440bcd1bb916 100644
--- a/app-crypt/libb2/libb2-0.98.1.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1.ebuild
@@ -45,9 +45,18 @@ src_configure() {
$(use_enable openmp)
}
-src_compile() {
+do_make() {
# respect our CFLAGS when native-cflags is not in effect
- emake $(use native-cflags && echo no)CFLAGS="${CFLAGS}"
+ local openmp=$(use openmp && echo -fopenmp)
+ emake $(use native-cflags && echo no)CFLAGS="${CFLAGS} ${openmp}" "$@"
+}
+
+src_compile() {
+ do_make
+}
+
+src_test() {
+ do_make check
}
src_install() {