summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonrpclib/Manifest1
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.3.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/Manifest b/dev-python/jsonrpclib/Manifest
index ce059b105bec..cda3cfd16183 100644
--- a/dev-python/jsonrpclib/Manifest
+++ b/dev-python/jsonrpclib/Manifest
@@ -1 +1,2 @@
DIST jsonrpclib-0.4.2.tar.gz 59590 BLAKE2B 4201d62c9be469d7016943acfc84dca56606f17383ac26e86f574c34927ee6131c5c1a9bc5c3934b8324049ac35b1ff5e4e49ca7ef850251ebdf9a42a53e59a4 SHA512 8d9e5ebe8de960272a1ea0a194544d41851f96c5bc16b9eb6984ac4e48ec1aeaee8e4c3846cfe747a737612934d43a3df72bb1267f0608b1cd2d6faba2acc7b2
+DIST jsonrpclib-0.4.3.2.gh.tar.gz 63127 BLAKE2B 4301f23a981f00e78f88f78a8f5e8d776985fcd5d268373430b308cd9e2b07d5e1aaae9fa514640275439f4269ecf9ac5a2e42d5c96b870b72e37e4faea7c790 SHA512 718b9a8a49b6f936635ea8e500d16b8d3f42a28e44c4d0bb2bf1e648063ab1107edca93b4f178600a0b36d2e0584cf531f6e9721f5ed6967ea9a160c923103f3
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.3.2.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.3.2.ebuild
new file mode 100644
index 000000000000..afe4f32dda97
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.4.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="
+ https://github.com/tcalmant/jsonrpclib/
+ https://pypi.org/project/jsonrpclib/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ test? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+
+ # NB: we need to run this test separately as it breaks
+ # tests/test_server.py::PooledServerTests
+ # see jsonlib.py, get_handler()
+ # the most preferred (first) lib that's in test deps
+ local -x JSONRPCLIB_TEST_EXPECTED_LIB=ujson
+ epytest tests/test_jsonlib.py::TestJsonLibLoading
+}