summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/hydrus/Manifest2
-rw-r--r--media-gfx/hydrus/hydrus-476.ebuild (renamed from media-gfx/hydrus/hydrus-469.ebuild)20
-rw-r--r--media-gfx/hydrus/hydrus-9999.ebuild20
3 files changed, 25 insertions, 17 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index 3cbed5835371..6feab9e3d28c 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -1,4 +1,4 @@
-DIST hydrus-469.tar.gz 39398328 BLAKE2B e10791db063c9cde1e204c353f27f4f1875e8a1f6981cf2d4f79fa6dbe55958be2ec310bdf77d640ff7b0cb7528870e34209cfde00035e1b29c75def524aa1e2 SHA512 b9416c195490fb7bc87fcaab58d79c1b13a63e577d0496ffae22ea901dfdd445a2b7b3197f0cc97c60339455fd2c687679f392787af5595cc167777364551485
DIST hydrus-472.tar.gz 39421962 BLAKE2B 2e7ac5d5169aed1d9437434514d878ce175bfe13116f8972b2a21532e0058ce09d9a55744e17b71d1755ebc8436d6f2ff4995dd81c9a49844aff42e60cd2564f SHA512 5b3eecf724fd2e6dede39bbf33665607294d7f345baf052fe379a241d6ee157550ca390d32bb1b256c1fee2224190b54ba9d7d0718ec10b147580eb1f5216b34
DIST hydrus-473.tar.gz 40044270 BLAKE2B 1aecc84aa60318fadffcf3ad3d8358fa4f537ca1ca55ae7ce02aade0e44b266f42ae94c423854874c471e1d8dc0988e232d19f2e5dd4e2d12834055b75814e9a SHA512 372e813deaef82fe02686e4d7fe5f9ab15476a954b53da8b3560a4cf45ad44209b22b727c32510714ff937b0e6116dae403b3a69954e51c5e62b67bea4eda808
DIST hydrus-474.tar.gz 40052948 BLAKE2B 7d323caf6dee2dc8a1dcf792a5c3383b395374d0e5a8fd88489b08a5b4ad295317cd5ae1da95d5435fb44ea8d4bbe4038d821c037c156e11d8b8c8a8582d67be SHA512 b73f5823ff84cf84710dd1fd9f9bfedffb6ce9ffaba8e4b23a7eda4a6a206aeaa8993632858fab9a5934f4c279fc23955cf045cd38af7ccf78b1eb73a0940bdb
+DIST hydrus-476.tar.gz 40139397 BLAKE2B 68a3f31a8f250b2c129a9f2562624ec98994e338112eba4f0953aa96dd95abdb97fc60f6a8f28efb5a660f543f596a344a13fe234b3ffb11e6a158b795b0a11c SHA512 5aa59cc2e4d72219d24de10eaeb99ad5b13c0de3af8d9c7e55e3ccea3b897077596401d4d034aac05c018a969f84507618f95ef70d422ac57075bf2d64a692c5
diff --git a/media-gfx/hydrus/hydrus-469.ebuild b/media-gfx/hydrus/hydrus-476.ebuild
index f45dbc3ac8ef..2e1663b11f1f 100644
--- a/media-gfx/hydrus/hydrus-469.ebuild
+++ b/media-gfx/hydrus/hydrus-476.ebuild
@@ -6,7 +6,10 @@ EAPI=7
PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="sqlite"
-inherit python-single-r1 desktop optfeature
+DOCS_BUILDER=mkdocs
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit python-single-r1 desktop docs optfeature
DESCRIPTION="A booru-like media organizer for the desktop"
HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
@@ -82,14 +85,13 @@ src_prepare() {
rm -r bin/ || die
# Build files used for CI, not actually needed
rm -r static/build_files || die
- # Duplicate license file, not needed
- rm license.txt || die
# Python requirements files, not needed
rm requirements_*.txt || die
}
src_compile() {
python_optimize "${S}"
+ docs_compile
}
src_test() {
@@ -107,18 +109,20 @@ src_install() {
mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
- local DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
- local HTML_DOCS=("${S}"/help/)
+ local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
einstalldocs
# Files only needed for testing
rm test.py hydrus/hydrus_test.py || die
rm -r hydrus/test/ static/testing/ || die
- # These files are copied into doc
- rm -r "${DOCS[@]}" "${HTML_DOCS[@]}" || die
+ # ${S}/_build = ${DOCS_OUTDIR}/.. and these have already been copied, remove it before installation
+ # ${DOCS[@]} files are copied into doc
+ # ${S}/docs/ is the markdown source code for documentation
+ # .gitignore/.github files aren't needed for the program to work, same with mkdocs files
+ rm -r "${S}/_build" "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
# The program expects to find documentation here, so add a symlink to doc
- dosym "${doc}/html/help" /opt/hydrus/help
+ dosym "${doc}/html" /opt/hydrus/help
insinto /opt/hydrus
doins -r "${S}"/.
diff --git a/media-gfx/hydrus/hydrus-9999.ebuild b/media-gfx/hydrus/hydrus-9999.ebuild
index f45dbc3ac8ef..2e1663b11f1f 100644
--- a/media-gfx/hydrus/hydrus-9999.ebuild
+++ b/media-gfx/hydrus/hydrus-9999.ebuild
@@ -6,7 +6,10 @@ EAPI=7
PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="sqlite"
-inherit python-single-r1 desktop optfeature
+DOCS_BUILDER=mkdocs
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit python-single-r1 desktop docs optfeature
DESCRIPTION="A booru-like media organizer for the desktop"
HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
@@ -82,14 +85,13 @@ src_prepare() {
rm -r bin/ || die
# Build files used for CI, not actually needed
rm -r static/build_files || die
- # Duplicate license file, not needed
- rm license.txt || die
# Python requirements files, not needed
rm requirements_*.txt || die
}
src_compile() {
python_optimize "${S}"
+ docs_compile
}
src_test() {
@@ -107,18 +109,20 @@ src_install() {
mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
- local DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
- local HTML_DOCS=("${S}"/help/)
+ local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
einstalldocs
# Files only needed for testing
rm test.py hydrus/hydrus_test.py || die
rm -r hydrus/test/ static/testing/ || die
- # These files are copied into doc
- rm -r "${DOCS[@]}" "${HTML_DOCS[@]}" || die
+ # ${S}/_build = ${DOCS_OUTDIR}/.. and these have already been copied, remove it before installation
+ # ${DOCS[@]} files are copied into doc
+ # ${S}/docs/ is the markdown source code for documentation
+ # .gitignore/.github files aren't needed for the program to work, same with mkdocs files
+ rm -r "${S}/_build" "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
# The program expects to find documentation here, so add a symlink to doc
- dosym "${doc}/html/help" /opt/hydrus/help
+ dosym "${doc}/html" /opt/hydrus/help
insinto /opt/hydrus
doins -r "${S}"/.