summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/xcdroast')
-rw-r--r--app-cdr/xcdroast/Manifest1
-rw-r--r--app-cdr/xcdroast/xcdroast-1.19.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-cdr/xcdroast/Manifest b/app-cdr/xcdroast/Manifest
index cd403a3fc812..704115751cac 100644
--- a/app-cdr/xcdroast/Manifest
+++ b/app-cdr/xcdroast/Manifest
@@ -1 +1,2 @@
DIST xcdroast-0.98alpha16.tar.gz 3563666 BLAKE2B 781f06e89265e9f30ea651d39219d7083a2cfc2833bc2ab0b57d9f67de77b2eb8aa6755148cd259e3c188a72f07026ecda91d0bbe09af4b55c696c75274739e0 SHA512 dec789955eb70a14f6bcb7c0895a6ca4b7c471cc5ee7ab12af1e671c8586c481c4a05e20eb42724d686d561a551809d9437dafadd3cd081079cefc28e0b94df7
+DIST xcdroast-1.19.tar.gz 3448552 BLAKE2B 2e4e2b5119d5002870142d95345ddd33dad40c5a9d7517594da0dfd945bea012d5391b61fb6264d790aaaacf4de6b990fc77f4b40fab594ac1a5d2279dafa933 SHA512 79449353ba5a1be990366e85bd807e4ef35ec19f021986634ee9549608dca0e447b61dbbed0f30f588baac49fc6b93c055800bedb629ff77274d7da7c39d7881
diff --git a/app-cdr/xcdroast/xcdroast-1.19.ebuild b/app-cdr/xcdroast/xcdroast-1.19.ebuild
new file mode 100644
index 000000000000..9db140ff8536
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-1.19.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop gnome2-utils
+
+DESCRIPTION="Lightweight cdrtools front-end for CD and DVD writing"
+HOMEPAGE="http://www.xcdroast.org/"
+SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls suid"
+
+RDEPEND=">=x11-libs/gtk+-2:2
+ >=app-cdr/cdrtools-3.02_alpha09"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable suid nonrootmode) \
+ --enable-gtk2 \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc
+}
+
+src_compile() {
+ emake PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ dodoc -r AUTHORS ChangeLog README doc/*
+
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins xpms/ico_cdwriter.xpm xcdroast.xpm
+
+ make_desktop_entry xcdroast "X-CD-Roast" xcdroast "AudioVideo;DiscBurning"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}