summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/filebus/filebus-0.0.1.ebuild')
-rw-r--r--app-misc/filebus/filebus-0.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/filebus/filebus-0.0.1.ebuild b/app-misc/filebus/filebus-0.0.1.ebuild
new file mode 100644
index 000000000000..e92d77e87298
--- /dev/null
+++ b/app-misc/filebus/filebus-0.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Multicast communication channels based on regular files"
+HOMEPAGE="https://github.com/zmedico/filebus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="+inotify test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )"
+BDEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test || die "tests failed for ${EPYTHON}"
+}