summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/khal')
-rw-r--r--app-misc/khal/khal-0.10.1-r2.ebuild (renamed from app-misc/khal/khal-0.10.1-r1.ebuild)19
-rw-r--r--app-misc/khal/khal-0.10.2-r1.ebuild (renamed from app-misc/khal/khal-0.10.2.ebuild)17
2 files changed, 15 insertions, 21 deletions
diff --git a/app-misc/khal/khal-0.10.1-r1.ebuild b/app-misc/khal/khal-0.10.1-r2.ebuild
index 6ef78da963d9..a4bd58a90c09 100644
--- a/app-misc/khal/khal-0.10.1-r1.ebuild
+++ b/app-misc/khal/khal-0.10.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_8 )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1
@@ -13,9 +13,8 @@ HOMEPAGE="http://lostpackets.de/khal/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
SLOT="0"
-IUSE="zsh-completion"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
>=dev-python/click-log-0.2.0[${PYTHON_USEDEP}]
@@ -27,9 +26,8 @@ RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
>=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- zsh-completion? ( app-shells/zsh )"
-DEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]"
+BDEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
dev-python/vdirsyncer[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]"
@@ -37,8 +35,7 @@ DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
src_install() {
distutils-r1_src_install
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/__khal
- fi
+
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
}
diff --git a/app-misc/khal/khal-0.10.2.ebuild b/app-misc/khal/khal-0.10.2-r1.ebuild
index 0c6dcfa5d3e9..0348736d1e30 100644
--- a/app-misc/khal/khal-0.10.2.ebuild
+++ b/app-misc/khal/khal-0.10.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1
@@ -13,9 +13,8 @@ HOMEPAGE="https://lostpackets.de/khal/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
SLOT="0"
-IUSE="zsh-completion"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/click-log[${PYTHON_USEDEP}]
@@ -27,9 +26,8 @@ RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
>=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- zsh-completion? ( app-shells/zsh )"
-DEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]"
+BDEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
dev-python/vdirsyncer[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]"
@@ -37,8 +35,7 @@ DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
src_install() {
distutils-r1_src_install
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/__khal
- fi
+
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
}