summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ofl/ofl-20110721.ebuild')
-rw-r--r--app-misc/ofl/ofl-20110721.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/ofl/ofl-20110721.ebuild b/app-misc/ofl/ofl-20110721.ebuild
new file mode 100644
index 000000000000..193ba1f2dbba
--- /dev/null
+++ b/app-misc/ofl/ofl-20110721.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open file lister (replaces fuser and lsof -m)"
+HOMEPAGE="http://jengelh.medozas.de/projects/hxtools/"
+SRC_URI="http://jftp.medozas.de/hxtools/hxtools-${PV}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=sys-libs/libhx-3.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/hxtools-${PV}
+
+src_configure() {
+ # We're just building a single utility. Don't bother
+ # with the build system.
+ :
+}
+
+src_compile() {
+ CC=$(tc-getCC) CFLAGS=${CFLAGS} LDLIBS="-lHX" \
+ emake V=1 -C sadmin ofl
+}
+
+src_install() {
+ dobin sadmin/ofl
+ doman doc/ofl.1
+}