summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/regex-markup/regex-markup-0.10.0.ebuild')
-rw-r--r--app-misc/regex-markup/regex-markup-0.10.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/regex-markup/regex-markup-0.10.0.ebuild b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
new file mode 100644
index 000000000000..b6ae39a6a8ec
--- /dev/null
+++ b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A tool to color syslog files as well"
+HOMEPAGE="http://www.nongnu.org/regex-markup/"
+SRC_URI="http://savannah.nongnu.org/download/regex-markup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples nls"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+}
+
+src_configure() {
+ econf \
+ --enable-largefile \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ if use examples; then
+ cd examples
+ emake -f Makefile
+ fi
+}