summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/blogc/blogc-9999.ebuild')
-rw-r--r--app-text/blogc/blogc-9999.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/app-text/blogc/blogc-9999.ebuild b/app-text/blogc/blogc-9999.ebuild
index ecc0d6aecdcd..7b4606390269 100644
--- a/app-text/blogc/blogc-9999.ebuild
+++ b/app-text/blogc/blogc-9999.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="git://github.com/blogc/blogc.git
+ EGIT_REPO_URI="
+ git://github.com/blogc/blogc.git
https://github.com/blogc/blogc.git"
inherit git-r3 autotools
fi
@@ -15,19 +16,12 @@ inherit eutils
DESCRIPTION="A blog compiler"
HOMEPAGE="http://blogc.org/"
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/beta/beta.}"
-
-MY_P="${PN}-${MY_PV}"
-
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
DEPEND="app-text/ronn"
-else
- S="${WORKDIR}/${MY_P}"
fi
LICENSE="BSD"
@@ -37,7 +31,7 @@ IUSE="test"
RDEPEND=""
# pkg-config is used only to find cmocka libraries
-DEPEND="${DEPEND}
+DEPEND="${RDEPEND}
test? (
virtual/pkgconfig
dev-util/cmocka )"