summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/coco')
-rw-r--r--dev-dotnet/coco/coco-2014.12.24-r2.ebuild (renamed from dev-dotnet/coco/coco-2014.12.24-r1.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-dotnet/coco/coco-2014.12.24-r1.ebuild b/dev-dotnet/coco/coco-2014.12.24-r2.ebuild
index 11dab3e015e6..259510cc2062 100644
--- a/dev-dotnet/coco/coco-2014.12.24-r1.ebuild
+++ b/dev-dotnet/coco/coco-2014.12.24-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DOTNET_PKG_COMPAT=6.0
+DOTNET_PKG_COMPAT=7.0
unset NUGET_PACKAGES
inherit dotnet-pkg
@@ -18,19 +18,21 @@ if [[ "${PV}" == *9999* ]] ; then
else
SRC_URI="https://github.com/boogie-org/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"
+
KEYWORDS="~amd64"
fi
LICENSE="GPL-2+"
SLOT="0"
+DOTNET_PKG_BUILD_EXTRA_ARGS=( -p:RollForward=Major )
DOTNET_PKG_PROJECTS=( "${S}/Coco.csproj" )
PATCHES=( "${FILESDIR}/${P}-Coco-csproj.patch" )
src_unpack() {
dotnet-pkg_src_unpack
- if [[ -n ${EGIT_REPO_URI} ]] ; then
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
git-r3_src_unpack
fi
}