summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/adjunctions/adjunctions-4.4.2.ebuild')
-rw-r--r--dev-haskell/adjunctions/adjunctions-4.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/adjunctions/adjunctions-4.4.2.ebuild b/dev-haskell/adjunctions/adjunctions-4.4.2.ebuild
new file mode 100644
index 000000000000..4c77a491faf4
--- /dev/null
+++ b/dev-haskell/adjunctions/adjunctions-4.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Adjunctions and representable functors"
+HOMEPAGE="https://github.com/ekmett/adjunctions/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ >=dev-haskell/contravariant-1:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/distributive-0.5.1:=[profile?] <dev-haskell/distributive-1:=[profile?]
+ >=dev-haskell/free-4:=[profile?] <dev-haskell/free-6:=[profile?]
+ >=dev-haskell/profunctors-4:=[profile?] <dev-haskell/profunctors-6:=[profile?]
+ >=dev-haskell/semigroupoids-4:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
+ >=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/void-0.5.5.1:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ >=dev-haskell/generic-deriving-1.11 <dev-haskell/generic-deriving-2
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ )
+"