summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/lvmlib/Manifest1
-rw-r--r--dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch87
-rw-r--r--dev-haskell/lvmlib/files/lvmlib-1.1-ghc-8.8.patch15
-rw-r--r--dev-haskell/lvmlib/files/lvmlib-1.1-ghc84.patch14
-rw-r--r--dev-haskell/lvmlib/lvmlib-1.1.ebuild32
-rw-r--r--dev-haskell/lvmlib/metadata.xml17
6 files changed, 0 insertions, 166 deletions
diff --git a/dev-haskell/lvmlib/Manifest b/dev-haskell/lvmlib/Manifest
deleted file mode 100644
index 0c3fc2b3db0f..000000000000
--- a/dev-haskell/lvmlib/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lvmlib-1.1.tar.gz 62388 BLAKE2B 9effe8b0b71ef36b3f73e792a9702d44efa5a7ed9f48f35825d75706a7dad2d5f5cac06d5941f60730c79216af5f3009110919dfa397343287e7359e702c5fbc SHA512 3f085f3ff8e53ab19de3b425c4c5a271111afcd334ec08fefd983838608ae436005c20c2d7c545650f0dd1b76d466f81661a14c8ce972df27d79a78c22023861
diff --git a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
deleted file mode 100644
index ad68d78f56e7..000000000000
--- a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-diff --git a/Lvm/Asm/Data.hs b/Lvm/Asm/Data.hs
-index 7939754..f3da0b7 100644
---- a/Lvm/Asm/Data.hs
-+++ b/Lvm/Asm/Data.hs
-@@ -17,2 +17,3 @@ import Lvm.Core.Module
- import Text.PrettyPrint.Leijen
-+import Prelude hiding ((<$>))
-
-diff --git a/Lvm/Common/IdMap.hs b/Lvm/Common/IdMap.hs
-index a50bcb6..10758e6 100644
---- a/Lvm/Common/IdMap.hs
-+++ b/Lvm/Common/IdMap.hs
-@@ -24,2 +24,3 @@ import Lvm.Common.Id
- import Control.Arrow (first)
-+import Prelude hiding (foldMap)
-
-diff --git a/Lvm/Core/Expr.hs b/Lvm/Core/Expr.hs
-index 8bc50d7..935e16a 100644
---- a/Lvm/Core/Expr.hs
-+++ b/Lvm/Core/Expr.hs
-@@ -17,2 +17,3 @@ import Lvm.Core.PrettyId
- import Text.PrettyPrint.Leijen
-+import Prelude hiding ((<$>))
-
-diff --git a/Lvm/Core/Module.hs b/Lvm/Core/Module.hs
-index 923870e..ac52201 100644
---- a/Lvm/Core/Module.hs
-+++ b/Lvm/Core/Module.hs
-@@ -24,2 +24,3 @@ import Lvm.Instr.Data
- import Text.PrettyPrint.Leijen
-+import Prelude hiding ((<$>))
-
-diff --git a/Lvm/Instr/Data.hs b/Lvm/Instr/Data.hs
-index 497a690..959cb5c 100644
---- a/Lvm/Instr/Data.hs
-+++ b/Lvm/Instr/Data.hs
-@@ -19,2 +19,3 @@ import Lvm.Common.Id
- import Text.PrettyPrint.Leijen
-+import Prelude hiding ((<$>))
-
-diff --git a/Lvm/Instr/Resolve.hs b/Lvm/Instr/Resolve.hs
-index 6845f74..4172a74 100644
---- a/Lvm/Instr/Resolve.hs
-+++ b/Lvm/Instr/Resolve.hs
-@@ -10,2 +10,4 @@ module Lvm.Instr.Resolve (instrResolve) where
- import Control.Exception (assert)
-+import Control.Applicative
-+import Control.Monad
- import Data.Maybe
-@@ -32,2 +34,6 @@ instance Functor Resolve where
-
-+instance Applicative Resolve where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad Resolve where
-diff --git a/Lvm/Read.hs b/Lvm/Read.hs
-index 7137331..25797f9 100644
---- a/Lvm/Read.hs
-+++ b/Lvm/Read.hs
-@@ -9,2 +9,3 @@ module Lvm.Read (lvmReadFile, lvmRead) where
-
-+import Control.Applicative
- import Control.Monad
-@@ -390,2 +391,7 @@ instance Functor (Read v) where
- Result x st2 -> Result (f x) st2)
-+
-+instance Applicative (Read v) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad (Read v) where
-diff --git a/Lvm/Write.hs b/Lvm/Write.hs
-index 48570f8..37469bc 100644
---- a/Lvm/Write.hs
-+++ b/Lvm/Write.hs
-@@ -11,2 +11,3 @@ import qualified Control.Exception as CE (assert, catch, IOException)
- import Control.Monad
-+import Control.Applicative
- import Data.Maybe
-@@ -465,2 +466,6 @@ instance Functor Emit where
-
-+instance Applicative Emit where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad Emit where
diff --git a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-8.8.patch b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-8.8.patch
deleted file mode 100644
index 36d680794f07..000000000000
--- a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-8.8.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Lvm/Common/IdMap.hs
-+++ b/Lvm/Common/IdMap.hs
-@@ -121,10 +121,10 @@ unionMaps :: [IdMap a] -> IdMap a
- unionMaps = foldr unionMap emptyMap
-
- foldMapWithId :: (Id -> a -> b -> b) -> b -> IdMap a -> b
--foldMapWithId f z (IdMap m) = IntMap.foldWithKey (f . idFromInt) z m
-+foldMapWithId f z (IdMap m) = IntMap.foldrWithKey (f . idFromInt) z m
-
- foldMap :: (a -> b -> b) -> b -> IdMap a -> b
--foldMap f z (IdMap m) = IntMap.fold f z m
-+foldMap f z (IdMap m) = IntMap.foldr f z m
-
- sizeMap :: IdMap a -> Int
- sizeMap (IdMap m) = IntMap.size m
diff --git a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc84.patch b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc84.patch
deleted file mode 100644
index 8f9e85402f9c..000000000000
--- a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc84.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Lvm/Common/Byte.hs
-+++ b/Lvm/Common/Byte.hs
-@@ -19,2 +19,3 @@ import System.Exit
- import System.IO
-+import qualified Data.Semigroup as S
-
-@@ -68,2 +69,7 @@ max32 = 2^(32::Int) -1 -- Bastiaan (Todo: check)
-
-+instance S.Semigroup Bytes where
-+ (<>) bs Nil = bs
-+ (<>) Nil cs = cs
-+ (<>) bs cs = Cat bs cs
-+
- instance Monoid Bytes where
diff --git a/dev-haskell/lvmlib/lvmlib-1.1.ebuild b/dev-haskell/lvmlib/lvmlib-1.1.ebuild
deleted file mode 100644
index 7184d226bf02..000000000000
--- a/dev-haskell/lvmlib/lvmlib-1.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit eutils haskell-cabal
-
-DESCRIPTION="The Lazy Virtual Machine (LVM)"
-HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/parsec:=[profile?]
- dev-haskell/wl-pprint:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10.1.0
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1-ghc-7.10.patch
- "${FILESDIR}"/${PN}-1.1-ghc84.patch
- "${FILESDIR}"/${PN}-1.1-ghc-8.8.patch
-)
diff --git a/dev-haskell/lvmlib/metadata.xml b/dev-haskell/lvmlib/metadata.xml
deleted file mode 100644
index 2d49cd8f1b3c..000000000000
--- a/dev-haskell/lvmlib/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- The Lazy Virtual Machine (LVM) defines a portable instruction set and file
- format. It is specifically designed to execute languages with non-strict (or
- lazy) semantics. This cabal package defines the core assembler (coreasm) for
- compiling core programs into LVM instructions and a library. The LVM is used
- as a backend for the Helium compiler. At the moment, one LVM runtime
- implementation is available (written in C). More information about LVM can be
- found in Chapter 6 of Daan Leijen's PhD Thesis, The Lambda Abroad.
- </longdescription>
-</pkgmetadata>