summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/flatbuffers')
-rw-r--r--dev-libs/flatbuffers/flatbuffers-1.8.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/flatbuffers/flatbuffers-1.8.0-r1.ebuild b/dev-libs/flatbuffers/flatbuffers-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..4a387f3894c1
--- /dev/null
+++ b/dev-libs/flatbuffers/flatbuffers-1.8.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Memory efficient serialization library"
+HOMEPAGE="https://google.github.io/flatbuffers/"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+
+src_configure() {
+ append-cppflags -std=c++11
+
+ local mycmakeargs=(
+ -DFLATBUFFERS_BUILD_FLATLIB=$(usex static-libs)
+ -DFLATBUFFERS_BUILD_SHAREDLIB=ON
+ -DFLATBUFFERS_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dobin "${CMAKE_BUILD_DIR}"/flatc
+}