summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/zthread')
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-clang.patch5
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff8
-rw-r--r--dev-libs/zthread/zthread-2.3.2-r4.ebuild21
3 files changed, 16 insertions, 18 deletions
diff --git a/dev-libs/zthread/files/zthread-2.3.2-clang.patch b/dev-libs/zthread/files/zthread-2.3.2-clang.patch
index 13dd91ea2ca5..3c0e07b9dc4a 100644
--- a/dev-libs/zthread/files/zthread-2.3.2-clang.patch
+++ b/dev-libs/zthread/files/zthread-2.3.2-clang.patch
@@ -2,9 +2,8 @@ fix compile when using clang as $CC:
Based on patch from https://bugs.launchpad.net/hugin/+bug/1213585 (rebased)
-diff -r 2a43e83684d5 src/foreign/zthread/include/zthread/Guard.h
---- a/include/zthread/Guard.h Sat Aug 10 11:31:46 2013 +0200
-+++ b/include/zthread/Guard.h Sun Aug 18 09:46:43 2013 +0200
+--- a/include/zthread/Guard.h
++++ b/include/zthread/Guard.h
@@ -108,7 +108,7 @@
}
diff --git a/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff
index 94b42eedfbf3..b8f68f59dd2a 100644
--- a/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff
+++ b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff
@@ -1,5 +1,5 @@
---- a/include/zthread/Guard.h 2008-07-22 14:46:28.000000000 +0200
-+++ b/include/zthread/Guard.h 2008-07-22 14:51:41.000000000 +0200
+--- a/include/zthread/Guard.h
++++ b/include/zthread/Guard.h
@@ -491,7 +491,7 @@
try {
@@ -9,8 +9,8 @@
LockingPolicy::destroyScope(*this);
} catch (...) { /* ignore */ }
---- a/src/MutexImpl.h 2008-07-22 14:54:40.000000000 +0200
-+++ b/src/MutexImpl.h 2008-07-22 15:03:30.000000000 +0200
+--- a/src/MutexImpl.h
++++ b/src/MutexImpl.h
@@ -153,7 +153,7 @@
_owner = self;
diff --git a/dev-libs/zthread/zthread-2.3.2-r4.ebuild b/dev-libs/zthread/zthread-2.3.2-r4.ebuild
index 02af2643693a..9d7decd68746 100644
--- a/dev-libs/zthread/zthread-2.3.2-r4.ebuild
+++ b/dev-libs/zthread/zthread-2.3.2-r4.ebuild
@@ -1,25 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils ltprune
+inherit autotools
MY_P="ZThread-${PV}"
DESCRIPTION="platform-independent multi-threading and synchronization library for C++"
HOMEPAGE="http://zthread.sourceforge.net/"
SRC_URI="mirror://sourceforge/zthread/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm64 ~hppa ~mips ppc ~sparc x86"
-IUSE="debug doc kernel_linux static-libs"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
+IUSE="debug doc kernel_linux"
-S="${WORKDIR}/${MY_P}"
+BDEPEND="doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}"/${P}-no-fpermissive-r1.diff
@@ -34,7 +32,8 @@ src_prepare() {
rm -f include/zthread/{.Barrier.h.swp,Barrier.h.orig} || die
- sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467778
+ # bug #467778
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
AT_M4DIR="share" eautoreconf
}
@@ -43,7 +42,7 @@ src_configure() {
econf \
$(use_enable debug) \
$(use_enable kernel_linux atomic-linux) \
- $(use_enable static-libs static)
+ --disable-static
}
src_compile() {
@@ -62,5 +61,5 @@ src_install() {
use doc && dodoc -r doc/html
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}