summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/Manifest1
-rw-r--r--dev-ml/camlzip/camlzip-1.05.ebuild35
-rw-r--r--dev-ml/camlzip/metadata.xml5
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
new file mode 100644
index 000000000000..bb47bb4bbd07
--- /dev/null
+++ b/dev-ml/camlzip/Manifest
@@ -0,0 +1 @@
+DIST camlzip-1.05.tar.gz 25817 SHA256 930b70c736ab5a7ed1b05220102310a0a2241564786657abe418e834a538d06b SHA512 5128243fc7528e5ec6cbb7d9b121e8cb0b6d486a95a82161cd74cafe05454602c9952ed6fee3d38a53614e5ecdc20ef88437681107c5952bf85b8f8c78bf042d WHIRLPOOL 26d2bf8d08a425b2297a913ec140fdfff78a31eb9a09e3641b38face44994c2f322354fddd9b96c003df74479e3d40dd12b5d9243160eeadd466b66e896b1acd
diff --git a/dev-ml/camlzip/camlzip-1.05.ebuild b/dev-ml/camlzip/camlzip-1.05.ebuild
new file mode 100644
index 000000000000..73d097ab0407
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.05.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1037/${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+
+ dodoc README Changes
+}
diff --git a/dev-ml/camlzip/metadata.xml b/dev-ml/camlzip/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/camlzip/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>