summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild')
-rw-r--r--dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild b/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
index a644d2daa385..f3ad68d7ea84 100644
--- a/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
+++ b/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit oasis
+inherit oasis eutils
DESCRIPTION="Optional compilation for OCaml"
HOMEPAGE="http://www.janestreet.com/ocaml"
@@ -20,6 +20,10 @@ DEPEND="dev-ml/ppx_tools:=
RDEPEND="${DEPEND}"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
+}
+
src_configure() {
emake setup.exe
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure