summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/PPIx-EditorTools')
-rw-r--r--dev-perl/PPIx-EditorTools/Manifest2
-rw-r--r--dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.170.0.ebuild30
-rw-r--r--dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.180.0.ebuild30
-rw-r--r--dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild31
-rw-r--r--dev-perl/PPIx-EditorTools/metadata.xml18
5 files changed, 111 insertions, 0 deletions
diff --git a/dev-perl/PPIx-EditorTools/Manifest b/dev-perl/PPIx-EditorTools/Manifest
new file mode 100644
index 000000000000..d81b0ff9a292
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/Manifest
@@ -0,0 +1,2 @@
+DIST PPIx-EditorTools-0.17.tar.gz 37993 SHA256 15b286eb41247372bf9034a3697d8be760af5cab47d6d947bbc60b03f9076d9a SHA512 468576bc06ec5ee61e4c988622e1f3e70bdaed7e775a0de67db4194113fc110e7d5091d5de1c3ab785430f79745cf9431dc46a1feb4300461110c4e290e58f58 WHIRLPOOL c5d071519c04f80198453a91cdcc4678cba49ef2fa2fb8eb498fbb5cc3d08ea700d2b6dc0ea408ca4bdf329db69580915031f2f6bf1b12f63e85b000e73d1003
+DIST PPIx-EditorTools-0.18.tar.gz 38874 SHA256 1dbe7d6c762b22f77943e7754bb02416f6f2412019c6ac5f1fcd3b327ffeee61 SHA512 84be683e7f745c3b5d57944d9f91f0fb53274c2c5bd9f1b252b76d9f0a531f4cc4fbe45592fb70da5f91f978493e2f7c723d4222d99ce73aeebfacfb97110d0a WHIRLPOOL da58d9dbdbe1fdc293443bf185b5b63fffcaa31a2a3ce88d09e09f640fe1f3797e312c3d4b773c832d2d4ea0c51de81ca4cb761ddc6154c6d016d3fc5a012a73
diff --git a/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.170.0.ebuild b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.170.0.ebuild
new file mode 100644
index 000000000000..be8636f7cf41
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.170.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SZABGAB
+MODULE_VERSION=0.17
+inherit perl-module
+
+DESCRIPTION="Utility methods and base class for manipulating Perl via PPI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-XSAccessor-1.20.0
+ >=dev-perl/PPI-1.215.0
+ >=dev-perl/Try-Tiny-0.110.0
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-Most
+ >=dev-perl/Test-Differences-0.480.100
+ dev-perl/Test-NoWarnings
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.180.0.ebuild b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.180.0.ebuild
new file mode 100644
index 000000000000..00db680df388
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.180.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SZABGAB
+MODULE_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="Utility methods and base class for manipulating Perl via PPI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-XSAccessor-1.20.0
+ >=dev-perl/PPI-1.215.0
+ >=dev-perl/Try-Tiny-0.110.0
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-Most
+ >=dev-perl/Test-Differences-0.480.100
+ dev-perl/Test-NoWarnings
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild
new file mode 100644
index 000000000000..76ca4a7d706f
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.190.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SZABGAB
+MODULE_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="Utility methods and base class for manipulating Perl via PPI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-XSAccessor-1.20.0
+ >=dev-perl/PPI-1.215.0
+ >=dev-perl/Try-Tiny-0.110.0
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-Most
+ >=dev-perl/Test-Differences-0.480.100
+ dev-perl/Test-NoWarnings
+ dev-perl/CPAN-Changes
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/PPIx-EditorTools/metadata.xml b/dev-perl/PPIx-EditorTools/metadata.xml
new file mode 100644
index 000000000000..61cb72cde726
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">PPIx-EditorTools</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::FindUnmatchedBrace</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::FindVariableDeclaration</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::IntroduceTemporaryVariable</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::Lexer</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::Outline</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::RenamePackage</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::RenamePackageFromPath</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::RenameVariable</remote-id>
+ <remote-id type="cpan-module">PPIx::EditorTools::ReturnObject</remote-id>
+ </upstream>
+</pkgmetadata>