summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-pam/pecl-pam-1.0.3-r1.ebuild')
-rw-r--r--dev-php/pecl-pam/pecl-pam-1.0.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/pecl-pam/pecl-pam-1.0.3-r1.ebuild b/dev-php/pecl-pam/pecl-pam-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..183094166c0f
--- /dev/null
+++ b/dev-php/pecl-pam/pecl-pam-1.0.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="pam"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2 pam
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="This extension provides PAM (Pluggable Authentication Modules) integration"
+LICENSE="PHP-2.02"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ my_conf="--with-pam=/usr $(use_enable debug)"
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ pamd_mimic_system php auth account password
+ php-ext-pecl-r2_src_install
+}