summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-classes/jaraco-classes-1.2.ebuild')
-rw-r--r--dev-python/jaraco-classes/jaraco-classes-1.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/jaraco-classes/jaraco-classes-1.2.ebuild b/dev-python/jaraco-classes/jaraco-classes-1.2.ebuild
deleted file mode 100644
index 41336f17a2a7..000000000000
--- a/dev-python/jaraco-classes/jaraco-classes-1.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Classes used by other projects by developer jaraco"
-HOMEPAGE="https://bitbucket.org/jaraco/jaraco.classes"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- dev-python/hgtools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- if use test && has_version "${CATEGORY}/${PN}"; then
- die "Ensure $PN is not already installed or the test suite will fail"
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}