summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jpype/jpype-0.6.2.ebuild')
-rw-r--r--dev-python/jpype/jpype-0.6.2.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/jpype/jpype-0.6.2.ebuild b/dev-python/jpype/jpype-0.6.2.ebuild
index 3ea7f1fefbc3..f8dfefc0dd22 100644
--- a/dev-python/jpype/jpype-0.6.2.ebuild
+++ b/dev-python/jpype/jpype-0.6.2.ebuild
@@ -22,6 +22,8 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=virtual/jdk-1.6"
+PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
+
python_compile() {
if ! python_is_python3; then
local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"