summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py2neo/py2neo-3.1.2.ebuild')
-rw-r--r--dev-python/py2neo/py2neo-3.1.2.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/dev-python/py2neo/py2neo-3.1.2.ebuild b/dev-python/py2neo/py2neo-3.1.2.ebuild
index 6d1fc20736fe..865ae1c8b842 100644
--- a/dev-python/py2neo/py2neo-3.1.2.ebuild
+++ b/dev-python/py2neo/py2neo-3.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+PYTHON_COMPAT=( python3_{5,6} pypy3 )
inherit distutils-r1
@@ -17,9 +17,3 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- # https://github.com/nigelsmall/py2neo/issues/380
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}