summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/pycuda-2012.1.ebuild4
-rw-r--r--dev-python/pycuda/pycuda-2013.1.1.ebuild4
-rw-r--r--dev-python/pycuda/pycuda-2014.1.ebuild2
-rw-r--r--dev-python/pycuda/pycuda-2016.1.2.ebuild2
-rw-r--r--dev-python/pycuda/pycuda-2017.1.ebuild2
-rw-r--r--dev-python/pycuda/pycuda-2018.1.1.ebuild2
-rw-r--r--dev-python/pycuda/pycuda-9999.ebuild2
7 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/pycuda/pycuda-2012.1.ebuild b/dev-python/pycuda/pycuda-2012.1.ebuild
index a2b3ca5a8819..21e49e486065 100644
--- a/dev-python/pycuda/pycuda-2012.1.ebuild
+++ b/dev-python/pycuda/pycuda-2012.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
# user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
python_prepare_all() {
cuda_sanitize
diff --git a/dev-python/pycuda/pycuda-2013.1.1.ebuild b/dev-python/pycuda/pycuda-2013.1.1.ebuild
index 64034046183c..46a77f6203c6 100644
--- a/dev-python/pycuda/pycuda-2013.1.1.ebuild
+++ b/dev-python/pycuda/pycuda-2013.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
# user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
python_prepare_all() {
cuda_sanitize
diff --git a/dev-python/pycuda/pycuda-2014.1.ebuild b/dev-python/pycuda/pycuda-2014.1.ebuild
index 211eb6a76d77..e72781d1161f 100644
--- a/dev-python/pycuda/pycuda-2014.1.ebuild
+++ b/dev-python/pycuda/pycuda-2014.1.ebuild
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
# user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
python_prepare_all() {
cuda_sanitize
diff --git a/dev-python/pycuda/pycuda-2016.1.2.ebuild b/dev-python/pycuda/pycuda-2016.1.2.ebuild
index 4267fea04c09..9875a9045d8e 100644
--- a/dev-python/pycuda/pycuda-2016.1.2.ebuild
+++ b/dev-python/pycuda/pycuda-2016.1.2.ebuild
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
# user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
python_prepare_all() {
cuda_sanitize
diff --git a/dev-python/pycuda/pycuda-2017.1.ebuild b/dev-python/pycuda/pycuda-2017.1.ebuild
index d0aeb99c15d1..7cffaca82606 100644
--- a/dev-python/pycuda/pycuda-2017.1.ebuild
+++ b/dev-python/pycuda/pycuda-2017.1.ebuild
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
# user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
python_prepare_all() {
cuda_sanitize
diff --git a/dev-python/pycuda/pycuda-2018.1.1.ebuild b/dev-python/pycuda/pycuda-2018.1.1.ebuild
index ea003a8275d7..23d3223f3ff7 100644
--- a/dev-python/pycuda/pycuda-2018.1.1.ebuild
+++ b/dev-python/pycuda/pycuda-2018.1.1.ebuild
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
# user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
python_prepare_all() {
cuda_sanitize
diff --git a/dev-python/pycuda/pycuda-9999.ebuild b/dev-python/pycuda/pycuda-9999.ebuild
index b289dbcddc6b..5b3ba1b64de0 100644
--- a/dev-python/pycuda/pycuda-9999.ebuild
+++ b/dev-python/pycuda/pycuda-9999.ebuild
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
# user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
python_prepare_all() {
cuda_sanitize