summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-augeas/python-augeas-1.1.0.ebuild')
-rw-r--r--dev-python/python-augeas/python-augeas-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-augeas/python-augeas-1.1.0.ebuild b/dev-python/python-augeas/python-augeas-1.1.0.ebuild
new file mode 100644
index 000000000000..42d631372089
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="app-admin/augeas
+ >=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/remove-tests.patch" )
+
+python_test() {
+ cd test && "${PYTHON}" test_augeas.py || die
+}