summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-cinderclient/python-cinderclient-8.0.0-r1.ebuild')
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-8.0.0-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/python-cinderclient/python-cinderclient-8.0.0-r1.ebuild b/dev-python/python-cinderclient/python-cinderclient-8.0.0-r1.ebuild
deleted file mode 100644
index 44576c3c75b6..000000000000
--- a/dev-python/python-cinderclient/python-cinderclient-8.0.0-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Cinder API"
-HOMEPAGE="https://launchpad.net/python-cinderclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/keystoneauth-4.2.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
- >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
- >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- dev-python/ddt[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/oslo-serialization[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/stestr[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- "${EPYTHON}" -m stestr run --debug || die "Tests failed with ${EPYTHON}"
-}